aboutsummaryrefslogtreecommitdiff
path: root/development/jupyter-qtconsole
diff options
context:
space:
mode:
authorIsaac Yu <isaacyu1@isaacyu1.com>2022-11-19 02:06:30 -0800
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-11-21 18:38:53 +0700
commitdb110984aa887012dffe02a7908976f5d379597d (patch)
treed707cf221c0937516682e310243dce6ef80a0ea0 /development/jupyter-qtconsole
parentcbb98b27d129ebbed84ab633872946880511cccd (diff)
development/jupyter-qtconsole: Update for 5.4.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/jupyter-qtconsole')
-rw-r--r--development/jupyter-qtconsole/doinst.sh3
-rw-r--r--development/jupyter-qtconsole/jupyter-qtconsole.SlackBuild8
-rw-r--r--development/jupyter-qtconsole/jupyter-qtconsole.info6
3 files changed, 13 insertions, 4 deletions
diff --git a/development/jupyter-qtconsole/doinst.sh b/development/jupyter-qtconsole/doinst.sh
new file mode 100644
index 0000000000000..5fb28930db0b9
--- /dev/null
+++ b/development/jupyter-qtconsole/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/development/jupyter-qtconsole/jupyter-qtconsole.SlackBuild b/development/jupyter-qtconsole/jupyter-qtconsole.SlackBuild
index 3343daf22bf44..1802fbc62fcd4 100644
--- a/development/jupyter-qtconsole/jupyter-qtconsole.SlackBuild
+++ b/development/jupyter-qtconsole/jupyter-qtconsole.SlackBuild
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyter-qtconsole
-VERSION=${VERSION:-5.3.2}
+VERSION=${VERSION:-5.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -87,6 +87,11 @@ python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# Add desktop icon
+SITE_PACKAGES=$(python3 -c "import site; print(site.getsitepackages()[0])")
+sed -i "s|^Icon=.*$|Icon=${SITE_PACKAGES}/qtconsole/resources/icon/JupyterConsole.svg|" examples/jupyter-qtconsole.desktop
+install -Dm644 examples/jupyter-qtconsole.desktop -t $PKG/usr/share/applications
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
CONTRIBUTING.md README.md LICENSE RELEASE.md \
@@ -95,6 +100,7 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/jupyter-qtconsole/jupyter-qtconsole.info b/development/jupyter-qtconsole/jupyter-qtconsole.info
index d196461d536e4..7a10051d8a0eb 100644
--- a/development/jupyter-qtconsole/jupyter-qtconsole.info
+++ b/development/jupyter-qtconsole/jupyter-qtconsole.info
@@ -1,8 +1,8 @@
PRGNAM="jupyter-qtconsole"
-VERSION="5.3.2"
+VERSION="5.4.0"
HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://github.com/jupyter/qtconsole/archive/5.3.2/qtconsole-5.3.2.tar.gz"
-MD5SUM="662535d97ac76ac414fd4ef6304fb588"
+DOWNLOAD="https://github.com/jupyter/qtconsole/archive/5.4.0/qtconsole-5.4.0.tar.gz"
+MD5SUM="19fd3ac0ab0ea7511dc9c98802076bc4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="jupyter-ipykernel QtPy"