aboutsummaryrefslogtreecommitdiff
path: root/development/jupyter-nbdime/jupyter-nbdime.SlackBuild
diff options
context:
space:
mode:
authorBenjamin Trigona-Harany <bosth@alumni.sfu.ca>2019-05-16 23:21:37 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2019-05-18 07:22:18 +0700
commit0fd3654c5227f8b6922d68ab8adae0bab22c5fdf (patch)
treed0cbecd62548b3542240d0a4ce9fd74179e1561a /development/jupyter-nbdime/jupyter-nbdime.SlackBuild
parentd29b436c8b90231ee72316ff957268c65c0e73a2 (diff)
downloadslackbuilds-0fd3654c5227f8b6922d68ab8adae0bab22c5fdf.tar.xz
development/jupyter-nbdime: Updated to use Python 3.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'development/jupyter-nbdime/jupyter-nbdime.SlackBuild')
-rw-r--r--development/jupyter-nbdime/jupyter-nbdime.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/development/jupyter-nbdime/jupyter-nbdime.SlackBuild b/development/jupyter-nbdime/jupyter-nbdime.SlackBuild
index 9146397a8f3f..34407016b3a7 100644
--- a/development/jupyter-nbdime/jupyter-nbdime.SlackBuild
+++ b/development/jupyter-nbdime/jupyter-nbdime.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for jupyter-nbdime
-# Copyright 2017-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
SRCNAM=nbdime
PRGNAM=jupyter-$SRCNAM
VERSION=${VERSION:-1.0.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -70,7 +70,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true