aboutsummaryrefslogtreecommitdiff
path: root/development/icdiff/icdiff.SlackBuild
diff options
context:
space:
mode:
authorB. Watson <yalhcru@gmail.com>2021-08-31 10:31:22 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-10-13 00:51:56 +0700
commitd7dff4b2d5d283fce746611d92affee7d3d02860 (patch)
tree1673f55aeda5edad303233c9db757858ab29a590 /development/icdiff/icdiff.SlackBuild
parent90fb3f22807b16134f5edc8f72eb39a32714882d (diff)
development/icdiff: Updated for version 2.0.4.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/icdiff/icdiff.SlackBuild')
-rw-r--r--development/icdiff/icdiff.SlackBuild23
1 files changed, 5 insertions, 18 deletions
diff --git a/development/icdiff/icdiff.SlackBuild b/development/icdiff/icdiff.SlackBuild
index 333f54ae4ad7..62bf70a0f745 100644
--- a/development/icdiff/icdiff.SlackBuild
+++ b/development/icdiff/icdiff.SlackBuild
@@ -6,10 +6,12 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20210831 bkw: updated for v2.0.4.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=icdiff
-VERSION=${VERSION:-1.9.5}
+VERSION=${VERSION:-2.0.4}
SRCVER=release-$VERSION
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -23,9 +25,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -61,19 +60,7 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-# patch from upstream git by way of Debian: Close stderr to prevent
-# printing errors when icdiff is piped to something that closes before
-# icdiff is done writing.
-patch -p1 < $CWD/fix-pipe-handling-installed.patch
-
-# 20201115 bkw: at some point, Slackware's /usr/bin/python will be python3.
-# This stuff can go away then.
-case "${PYVER:-auto}" in
- 2|3) ;; # use as-is
- auto) PYVER=2; python3 -c 'import sys' 2>/dev/null && PYVER=3 ;;
-esac
-
-python$PYVER setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
# man page made from README.md by SlackBuild author.
mkdir -p $PKG/usr/man/man1
@@ -81,7 +68,7 @@ gzip -9c < $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
ln -s $PRGNAM.1.gz $PKG/usr/man/man1/git-$PRGNAM.1.gz
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README* LICENSE* $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README* LICENSE* ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install