aboutsummaryrefslogtreecommitdiff
path: root/development/codespell/codespell.SlackBuild
diff options
context:
space:
mode:
authorB. Watson <yalhcru@gmail.com>2021-08-29 14:10:23 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-10-13 00:51:53 +0700
commitfa576b482fddd1c122e92d821b54c7fb552cd749 (patch)
tree961155c789e5de1f084ca62fa56a757a0b842146 /development/codespell/codespell.SlackBuild
parent45128e81cdc3397d3321ba500eacadb865e6ac3c (diff)
development/codespell: Updated for version 2.1.0.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/codespell/codespell.SlackBuild')
-rw-r--r--development/codespell/codespell.SlackBuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/development/codespell/codespell.SlackBuild b/development/codespell/codespell.SlackBuild
index dc5a030638091..5070146e11225 100644
--- a/development/codespell/codespell.SlackBuild
+++ b/development/codespell/codespell.SlackBuild
@@ -6,10 +6,16 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20210829 bkw:
+# - update for 2.1.0.
+# - use python3 by default. add PYVER var to force building with 2,
+# but don't document it (nobody should need it).
+# - add example/ to the doc dir.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=codespell
-VERSION=${VERSION:-1.17.1}
+VERSION=${VERSION:-2.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -22,9 +28,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -60,14 +63,14 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-python setup.py install --root=$PKG
+python${PYVER:-3} setup.py install --root=$PKG
make $PRGNAM.1
mkdir -p $PKG/usr/man/man1
gzip -9c < $PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README* COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README* COPYING example $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install