aboutsummaryrefslogtreecommitdiff
path: root/desktop/wmmon/patches
diff options
context:
space:
mode:
authorB. Watson <yalhcru@gmail.com>2019-12-12 03:18:06 -0500
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2019-12-15 17:06:28 +0700
commite9b011fb5c34eb671159ae1d8398e9657353f7bc (patch)
tree302e8ca092d8280e1edbb274a2a2340a34a68708 /desktop/wmmon/patches
parentd94c672c17631f201aabd1671fa1b510e0b23541 (diff)
desktop/wmmon: Updated for version 1.4.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'desktop/wmmon/patches')
-rw-r--r--desktop/wmmon/patches/gcc5.diff18
-rw-r--r--desktop/wmmon/patches/manpage_window_not_clock.diff21
-rw-r--r--desktop/wmmon/patches/rc_file_parser.diff12
3 files changed, 0 insertions, 51 deletions
diff --git a/desktop/wmmon/patches/gcc5.diff b/desktop/wmmon/patches/gcc5.diff
deleted file mode 100644
index 1d02bddb48a7f..0000000000000
--- a/desktop/wmmon/patches/gcc5.diff
+++ /dev/null
@@ -1,18 +0,0 @@
-Description: fix build failure with gcc5:
- build with "-std=gnu89"
-Origin: vendor
-Bug-Debian: https://bugs.debian.org/778171
-Author: gregor herrmann <gregoa@debian.org>
-Last-Update: 2015-07-19
-
---- a/wmmon/Makefile
-+++ b/wmmon/Makefile
-@@ -5,7 +5,7 @@
- ../wmgeneral/misc.o \
- ../wmgeneral/list.o
-
--CFLAGS = -O2
-+CFLAGS = -O2 -std=gnu89
- CC = cc
-
-
diff --git a/desktop/wmmon/patches/manpage_window_not_clock.diff b/desktop/wmmon/patches/manpage_window_not_clock.diff
deleted file mode 100644
index d32d08ee2d625..0000000000000
--- a/desktop/wmmon/patches/manpage_window_not_clock.diff
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naur wmmon.app/wmmon/wmmon.1 wmmon.app.patched/wmmon/wmmon.1
---- wmmon.app/wmmon/wmmon.1 2009-04-20 17:55:39.000000000 -0400
-+++ wmmon.app.patched/wmmon/wmmon.1 2009-04-20 17:56:52.000000000 -0400
-@@ -64,7 +64,7 @@
-
- .TP
- .BI \-geometry \ geometry
--This option specifies the preferred position of clock; see
-+This option specifies the preferred position of the window; see
- .IR X(7x) .
-
- .TP
-@@ -159,7 +159,7 @@
- .B WMMon
- detects a
- .I $HOME/.wmmonrc
--file, it will launch the appropriate command when you click on the clock.
-+file, it will launch the appropriate command when you click on the window.
-
- The system administrator can define default commands in
- .IR /etc/wmmonrc .
diff --git a/desktop/wmmon/patches/rc_file_parser.diff b/desktop/wmmon/patches/rc_file_parser.diff
deleted file mode 100644
index 376fcc72d13fe..0000000000000
--- a/desktop/wmmon/patches/rc_file_parser.diff
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur wmmon.app/wmgeneral/wmgeneral.c wmmon.app.patched/wmgeneral/wmgeneral.c
---- wmmon.app/wmgeneral/wmgeneral.c 2009-04-20 17:03:25.000000000 -0400
-+++ wmmon.app.patched/wmgeneral/wmgeneral.c 2009-04-20 17:02:58.000000000 -0400
-@@ -95,6 +95,8 @@
- fp = fopen(filename, "r");
- if (fp) {
- while (getline(&line, &line_size, fp) >= 0) {
-+ if(*line == '#')
-+ continue;
- key = 0;
- while (key >= 0 && keys[key].label) {
- if ((p = strstr(line, keys[key].label))) {