aboutsummaryrefslogtreecommitdiff
path: root/audio/yabridge
diff options
context:
space:
mode:
authorMartin Bångens <noisecode3@gmail.com>2023-12-31 11:30:01 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-12-31 21:01:36 +0700
commit4100450acfb2776f3f702efb9882adae1a070801 (patch)
treeaa24a83fbdfbac8a8f79a5d98a87a1a5f45991ef /audio/yabridge
parentaa17592e7225cdc9d0a7a9461e2024c122e5e66c (diff)
audio/yabridge: Updated for version 5.1.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'audio/yabridge')
-rw-r--r--audio/yabridge/README14
-rw-r--r--audio/yabridge/yabridge.SlackBuild69
-rw-r--r--audio/yabridge/yabridge.info14
3 files changed, 80 insertions, 17 deletions
diff --git a/audio/yabridge/README b/audio/yabridge/README
index 55537fdb9ec0d..fe52bc548737e 100644
--- a/audio/yabridge/README
+++ b/audio/yabridge/README
@@ -9,8 +9,9 @@ and highly compatible, while also staying easy to debug and maintain.
This script will build yabridge bitbridge both 64bit and 32bit
on Slackware64 and only 32bit plugin host on Slackware32 with
yabridgectl helper tool for all versions of Slackware.
-This program depends on any 64+32 (Slackware64) or 32 (Slackware32)
-version of wine with esync and/or fsync. No ARM support yet.
+This program depends on any 64+32 (Slackware64 multilib) or
+a 32 (Slackware32) version of wine with esync and/or fsync.
+No ARM support yet.
Make sure you have configured you're system with real-time priority.
visit https://docs.slackware.com and search: minimizing_latency
@@ -20,9 +21,16 @@ You can set them in /etc/profile like this:
export WINEFSYNC=1
export WINEESYNC=1
+build options
+ARG_CLAP="false"
+ARG_VST3="true"
+ARG_WINEDGB="false"
+
Read the documentation in /usr/doc/yabridge-*
-OPTIONAL DEPENDENCIES NOT NEEDED FOR COMPILING
+OPTIONAL DEPENDENCIES NEEDED FOR COMPILING
+clap
+OPTIONAL DEPENDENCIES
winetricks: For correct fonts displayed by plugins
rtirq: For better latency of audio peripherals
diff --git a/audio/yabridge/yabridge.SlackBuild b/audio/yabridge/yabridge.SlackBuild
index 81a05b0be7c24..635ba0f1803b7 100644
--- a/audio/yabridge/yabridge.SlackBuild
+++ b/audio/yabridge/yabridge.SlackBuild
@@ -22,14 +22,17 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-cd $(dirname $0) ; CWD=$(pwd)
+cd $(dirname $0) || exit 1 ; CWD=$(pwd)
PRGNAM=yabridge
-VERSION=${VERSION:-5.0.5}
+VERSION=${VERSION:-5.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-
+ARG_CLAP=${ARG_CLAP:-NO}
+ARG_VST3=${ARG_VST3:-YES}
+ARG_WINEDGB=${ARG_WINEDGB:-NO}
+#false/true
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -38,6 +41,24 @@ if [ -z "$ARCH" ]; then
esac
fi
+if [[ "$ARG_CLAP" = "YES" || "$ARG_CLAP" = "true" ]]; then
+ ARG_CLAP="true"
+else
+ ARG_CLAP="false"
+fi
+
+if [[ "$ARG_VST3" = "YES" || "$ARG_VST3" = "true" ]]; then
+ ARG_VST3="true"
+else
+ ARG_VST3="false"
+fi
+
+if [[ "$ARG_WINEDGB" = "YES" || "$ARG_WINEDGB" = "true" ]]; then
+ ARG_WINEDGB="true"
+else
+ ARG_WINEDGB="false"
+fi
+
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
@@ -57,17 +78,26 @@ which wine64 &>/dev/null
WINE64_IN_PATH=$?
if [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ]; then
+ LIBDIRSUFFIX=""
if (($WINE_IN_PATH)); then
echo "This script look for wine in PATH and needs it for compiling and using yabridge on i586"
exit 1
fi
elif [ $ARCH = "x86_64" ]; then
+ LIBDIRSUFFIX="64"
if (($WINE_IN_PATH)) || (($WINE64_IN_PATH)); then
echo "This script look for wine and wine64 in PATH and needs them both for compiling and using yabridge on x86_64"
exit 1
fi
fi
+export PATH="/opt/rust16/bin:$PATH"
+if [ -z "$LD_LIBRARY_PATH" ]; then
+ export LD_LIBRARY_PATH="/opt/rust16/lib$LIBDIRSUFFIX"
+else
+ export LD_LIBRARY_PATH="/opt/rust16/lib$LIBDIRSUFFIX:$LD_LIBRARY_PATH"
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -94,8 +124,9 @@ sed -i "s|bitsery_dep = dependency('bitsery', version : '>=5.2.0')|bitsery_dep =
sed -i "s|bitsery_dep = dependency('bitsery', 'Bitsery', version : '>=5.2.0')|bitsery_dep = dependency('Bitsery', version : '>=5.2.0')|g" meson.build
mkdir subprojects/vst3
-cp -a /usr/include/vst3sdk/* subprojects/vst3/
+tar xvzf $CWD/vst3sdk-3.7.7.tar.gz --strip-components=1 -C subprojects/vst3
cp yabridge-html-docs-plus-build-files-$VERSION/meson.build subprojects/vst3
+
if [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ]; then
meson setup \
build \
@@ -105,6 +136,9 @@ if [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ]; then
--unity-size=1000 \
--wrap-mode=nodownload \
-Dbitbridge=true \
+ -Dclap=$ARG_CLAP \
+ -Dvst3=$ARG_VST3 \
+ -Dwinedgb=$ARG_WINEDGB \
-Dsystem-asio=true \
-Dbuild.cpp_args='-m32' \
-Dbuild.cpp_link_args='-m32'
@@ -117,6 +151,9 @@ elif [ "$ARCH" = "x86_64" ]; then
--unity-size=1000 \
--wrap-mode=nodownload \
-Dbitbridge=true \
+ -Dclap=$ARG_CLAP \
+ -Dvst3=$ARG_VST3 \
+ -Dwinedgb=$ARG_WINEDGB \
-Dsystem-asio=true
else
echo "Unsupported architecture"
@@ -147,14 +184,30 @@ install -dm755 "$PKG/usr/bin"
if [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ]; then
install yabridge-host-32.exe{,.so} "$PKG/usr/bin"
install -dm755 "$PKG/usr/lib"
- install libyabridge-{vst2,vst3,clap}.so "$PKG/usr/lib"
- install libyabridge-chainloader-{vst2,vst3,clap}.so "$PKG/usr/lib"
+ install libyabridge-vst2.so "$PKG/usr/lib"
+ install libyabridge-chainloader-vst2.so "$PKG/usr/lib"
+ if [ $ARG_VST3 = "true" ]; then
+ install libyabridge-vst3.so "$PKG/usr/lib"
+ install libyabridge-chainloader-vst3.so "$PKG/usr/lib"
+ fi
+ if [ $ARG_CLAP = "true" ]; then
+ install libyabridge-clap.so "$PKG/usr/lib"
+ install libyabridge-chainloader-clap.so "$PKG/usr/lib"
+ fi
elif [ "$ARCH" = "x86_64" ]; then
install yabridge-host.exe{,.so} "$PKG/usr/bin"
install yabridge-host-32.exe{,.so} "$PKG/usr/bin"
install -dm755 "$PKG/usr/lib64"
- install libyabridge-{vst2,vst3,clap}.so "$PKG/usr/lib64"
- install libyabridge-chainloader-{vst2,vst3,clap}.so "$PKG/usr/lib64"
+ install libyabridge-vst2.so "$PKG/usr/lib64"
+ install libyabridge-chainloader-vst2.so "$PKG/usr/lib64"
+ if [ $ARG_VST3 = "true" ]; then
+ install libyabridge-vst3.so "$PKG/usr/lib64"
+ install libyabridge-chainloader-vst3.so "$PKG/usr/lib64"
+ fi
+ if [ $ARG_CLAP = "true" ]; then
+ install libyabridge-clap.so "$PKG/usr/lib64"
+ install libyabridge-chainloader-clap.so "$PKG/usr/lib64"
+ fi
fi
install ../tools/yabridgectl/target/release/yabridgectl "$PKG/usr/bin"
diff --git a/audio/yabridge/yabridge.info b/audio/yabridge/yabridge.info
index a76748bb3ed52..b5c35ef8985e2 100644
--- a/audio/yabridge/yabridge.info
+++ b/audio/yabridge/yabridge.info
@@ -1,12 +1,14 @@
PRGNAM="yabridge"
-VERSION="5.0.5"
+VERSION="5.1.0"
HOMEPAGE="https://github.com/robbert-vdh/yabridge"
-DOWNLOAD="https://github.com/robbert-vdh/yabridge/archive/5.0.5/yabridge-5.0.5.tar.gz \
- https://github.com/noisecode3/yabridge-html-docs-plus-build-files/archive/v5.0.5/yabridge-html-docs-plus-build-files-5.0.5.tar.gz"
-MD5SUM="fb6fceb42fda6d29b3989d4cb6cb4825 \
- aa27d03940adf503d4b727aa0e78dc4d"
+DOWNLOAD="https://github.com/robbert-vdh/yabridge/archive/5.1.0/yabridge-5.1.0.tar.gz \
+ https://github.com/noisecode3/vst3sdk/archive/3.7.7/vst3sdk-3.7.7.tar.gz \
+ https://github.com/noisecode3/yabridge-html-docs-plus-build-files/archive/v5.1.0/yabridge-html-docs-plus-build-files-5.1.0.tar.gz"
+MD5SUM="2383d67c9089a4fda8ae311baaa8fe3b \
+ f9e2185ea8cdfbdc4d99c4a5f5e4d426 \
+ a58876a05ac16ada09f750a4b8564443"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="%README% wine-staging asio bitsery function2 ghc_filesystem tomlplusplus vst3sdk clap"
+REQUIRES="%README% wine-staging asio bitsery function2 ghc_filesystem tomlplusplus rust16"
MAINTAINER="Martin Bångens"
EMAIL="marbangens@gmail.com"