aboutsummaryrefslogtreecommitdiff
path: root/academic/pysam/pysam.SlackBuild
diff options
context:
space:
mode:
authorbrobr <sborg63@disroot.org>2021-10-15 12:33:57 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-10-16 00:11:26 +0700
commit6ceff5e7684573b8bce28fe5ec18a02494076a8d (patch)
treeedbe9882cb3193ec40f8418474de132e10f1be23 /academic/pysam/pysam.SlackBuild
parent8d08e24ecc82e5490db241c7c4a4702ea37b7709 (diff)
academic/pysam: Updated for version 0.17.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic/pysam/pysam.SlackBuild')
-rw-r--r--academic/pysam/pysam.SlackBuild23
1 files changed, 6 insertions, 17 deletions
diff --git a/academic/pysam/pysam.SlackBuild b/academic/pysam/pysam.SlackBuild
index 1daa466668941..55994c96949e1 100644
--- a/academic/pysam/pysam.SlackBuild
+++ b/academic/pysam/pysam.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pysam
-# Copyright 2017-2020 Rob van Nues
+# Copyright 2017-2021 Rob van Nues
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,19 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pysam
-VERSION=${VERSION:-0.16.0.1}
+VERSION=${VERSION:-0.17.0}
BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-#set which python version to install it for
-PYTHON2=false
-PYTHON3=true
-
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -85,21 +80,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-### pysam linked to htslib-1.10; SBo-htslib is at 1.11:
+### pysam linked to htslib-1.13; SBo-htslib is at 1.13:
##use system htslib:
-#export HTSLIB_LIBRARY_DIR=/usr/lib$LIBDIRSUFFIX
-#export HTSLIB_INCLUDE_DIR=/usr/include
+export HTSLIB_LIBRARY_DIR=/usr/lib$LIBDIRSUFFIX
+export HTSLIB_INCLUDE_DIR=/usr/include
#the source does not allow 'read' to 'other', which could cause a problem on reloading a Jupyter-notebook
chmod 644 pysam.egg-info/*
-
-if $PYTHON2; then
- python setup.py install --root=$PKG
-fi
-if $PYTHON3; then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true