aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-10-20 18:02:46 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-10-21 08:16:13 +0700
commit0bb47a7065e28245d638c009463a6a122d12d68b (patch)
treeb2f375994e9c52e8e61f8386f60d8aa1f23e1d32
parentc084eff5f03922fba7b4c6c4e93a755ea0579b81 (diff)
python/cryptography: Updated for version 43.0.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/cryptography/cryptography.SlackBuild9
-rw-r--r--python/cryptography/cryptography.info10
-rw-r--r--python/cryptography/mkvendored.sh4
3 files changed, 13 insertions, 10 deletions
diff --git a/python/cryptography/cryptography.SlackBuild b/python/cryptography/cryptography.SlackBuild
index 1b3de44f9fac..f62a8e83d34a 100644
--- a/python/cryptography/cryptography.SlackBuild
+++ b/python/cryptography/cryptography.SlackBuild
@@ -26,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=cryptography
-VERSION=${VERSION:-43.0.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-43.0.3}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
VSBUILD=${VSBUILD:-1}
@@ -81,6 +81,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -i "s|!=74.1.2,||g" pyproject.toml
+sed -i "s|,!=75.2.0||g" pyproject.toml
+
# prevent cargo from using the network.
# this only works because we have a vendored sources tarball with
# everything cargo would have downloaded.
@@ -107,7 +110,7 @@ python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-rm -rf docs/_static/ # 20220408 bkw: empty dir
+rm -rf docs/_static/
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -ar LICENSE* *.rst docs/ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/cryptography/cryptography.info b/python/cryptography/cryptography.info
index 46e17e0ef7d4..983b41b2a646 100644
--- a/python/cryptography/cryptography.info
+++ b/python/cryptography/cryptography.info
@@ -1,10 +1,10 @@
PRGNAM="cryptography"
-VERSION="43.0.1"
+VERSION="43.0.3"
HOMEPAGE="https://cryptography.io/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/c/cryptography/cryptography-43.0.1.tar.gz \
- https://sbo-source.s3.ap-southeast-1.amazonaws.com/cryptography-vendored-sources-43.0.1-1.tar.xz"
-MD5SUM="098045b2e33051979efab7a0a9880e0f \
- fa5e7596cea0af0e1473ada610eed062"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/c/cryptography/cryptography-43.0.3.tar.gz \
+ https://sbo-source.s3.ap-southeast-1.amazonaws.com/cryptography-vendored-sources-43.0.3-1.tar.xz"
+MD5SUM="e0669c198e0aecdcd68a2adef030f5a6 \
+ 2059e7e954b9fd6b113e94a962929872"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-maturin"
diff --git a/python/cryptography/mkvendored.sh b/python/cryptography/mkvendored.sh
index 47d498e7a95b..c57fdf8e9583 100644
--- a/python/cryptography/mkvendored.sh
+++ b/python/cryptography/mkvendored.sh
@@ -87,8 +87,8 @@ else
LIBDIRSUFFIX=""
fi
-# check if rust-opt is installed
-if [ ! -d /opt/rust/bin ]; then
+# check if rust-opt is installed or in current, default cargo from rust is enough
+if [[ ! -d /opt/rust/bin && ! -f /usr/bin/cargo ]]; then
echo "ERROR: The rust-opt slackbuild is required to be installed"
exit 1
else