aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-15 16:28:48 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-19 18:40:20 +0700
commitf36971d3081f5737a7034bb83d549279366f24cb (patch)
tree5a19db14289919e5dde9aa1dc2034dcab6af4904
parent37d3ab125a367f58cb6c30080fc609ad39c2e564 (diff)
python/requirements-detector: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/requirements-detector/requirements-detector.SlackBuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/python/requirements-detector/requirements-detector.SlackBuild b/python/requirements-detector/requirements-detector.SlackBuild
index d07df4f9e41d4..6975ae7dd02b8 100644
--- a/python/requirements-detector/requirements-detector.SlackBuild
+++ b/python/requirements-detector/requirements-detector.SlackBuild
@@ -69,7 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true