aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Wagner <slackware.wagnerm@arcor.de>2010-05-12 23:32:18 +0200
committerMichiel van Wessem <michiel@slackbuilds.org>2010-05-12 23:32:18 +0200
commit4a3fd527941ac66e06f4e54ee1dcffe531dbfdff (patch)
treef5b9bdcecf6495168dbafee2cc98a1db0ab424c1
parent70eb5f109f3e8e0906f54139677965735799ec36 (diff)
network/kitchensync: Added to 12.2 repository
-rw-r--r--network/kitchensync/README9
-rw-r--r--network/kitchensync/kitchensync.SlackBuild85
-rw-r--r--network/kitchensync/kitchensync.info9
-rw-r--r--network/kitchensync/slack-desc19
4 files changed, 122 insertions, 0 deletions
diff --git a/network/kitchensync/README b/network/kitchensync/README
new file mode 100644
index 000000000000..d74e77db2b8d
--- /dev/null
+++ b/network/kitchensync/README
@@ -0,0 +1,9 @@
+KitchenSync: Syncing PIM Data
+
+KitchenSync is the KDE frontend to the universal standard syncing
+solution OpenSync. It can be used to sync PDAs, mobile phones
+or other computers with the KDE desktop and some other applications.
+
+KitchenSync depends on libopensync, which is available from Slackbuilds.org.
+
+Homepage: http://www.kontact.org/kitchensync/
diff --git a/network/kitchensync/kitchensync.SlackBuild b/network/kitchensync/kitchensync.SlackBuild
new file mode 100644
index 000000000000..e24cb20b853a
--- /dev/null
+++ b/network/kitchensync/kitchensync.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for kitchensync
+
+# (C) 2008 Michael Wagner <slackware.wagnerm@arcor.de>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=kitchensync
+VERSION=3.5.10
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+SRCNAM=kdepim
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Avoid a version number in .la files:
+if [ -d /usr/lib/qt ]; then
+ QTDIR=/usr/lib/qt
+fi
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure --prefix=/usr
+
+cd $PRGNAM
+
+# Use already installed libtool archives
+for i in libkdepim libkcal; do
+ sed -i "s,\$(top_builddir)/$i/$i.la,/usr/lib/$i.la,g" src/Makefile.in
+done
+
+make
+make install-strip DESTDIR=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/network/kitchensync/kitchensync.info b/network/kitchensync/kitchensync.info
new file mode 100644
index 000000000000..35646232e132
--- /dev/null
+++ b/network/kitchensync/kitchensync.info
@@ -0,0 +1,9 @@
+PRGNAM="kitchensync"
+VERSION="3.5.10"
+HOMEPAGE="http://www.kontact.org/kitchensync/"
+DOWNLOAD="http://download.kde.org/stable/3.5.10/src/kdepim-3.5.10.tar.bz2"
+MD5SUM="fc93e458a8eec8131ede56cff30c28b2"
+MAINTAINER="Michael Wagner"
+EMAIL="slackware.wagnerm@arcor.de"
+APPROVED="Michiel"
+
diff --git a/network/kitchensync/slack-desc b/network/kitchensync/slack-desc
new file mode 100644
index 000000000000..9ea69a20936f
--- /dev/null
+++ b/network/kitchensync/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+kitchensync: KitchenSync (a KDE tool for Syncing PIM Data)
+kitchensync:
+kitchensync: KitchenSync is the KDE frontend to the universal standard syncing
+kitchensync: solution OpenSync. It can be used to sync PDAs, mobile phones
+kitchensync: or other computers with the KDE desktop and some other applications.
+kitchensync:
+kitchensync: Homepage: http://www.kontact.org/kitchensync/
+kitchensync:
+kitchensync:
+kitchensync:
+kitchensync: