aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiels Horn <niels.horn@slackbuilds.org>2011-03-09 22:24:09 -0300
committerRobby Workman <rworkman@slackbuilds.org>2011-03-20 14:07:56 -0500
commit93d4ecdfe4d14f2047c48405d6fdfac214080c98 (patch)
tree0e194d308e51a57a7a81a4394441325245e22f17
parent89ed7e0e9cea616bcb82fe71107eb33b1ce4b7b7 (diff)
downloadslackbuilds-93d4ecdfe4d14f2047c48405d6fdfac214080c98.tar.xz
libraries/libvmime-zarafa: Adapted for Slackware 13.37
Added patch for newer gcc versions. Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
-rw-r--r--libraries/libvmime-zarafa/libvmime-zarafa.SlackBuild8
-rw-r--r--libraries/libvmime-zarafa/patches/libvmime_signal.patch10
2 files changed, 14 insertions, 4 deletions
diff --git a/libraries/libvmime-zarafa/libvmime-zarafa.SlackBuild b/libraries/libvmime-zarafa/libvmime-zarafa.SlackBuild
index 7b6247911125..f899a96e7b66 100644
--- a/libraries/libvmime-zarafa/libvmime-zarafa.SlackBuild
+++ b/libraries/libvmime-zarafa/libvmime-zarafa.SlackBuild
@@ -5,19 +5,17 @@
# (with patches from zarafa)
# Written by Niels Horn <niels.horn@gmail.com>
-# revision date 2010/05/27
+# revision date 2011/03/09
PRGNAM=libvmime-zarafa
VERSION=${VERSION:-0.7.1_p20100503}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -67,6 +65,8 @@ done
patch -p1 < $CWD/patches/flags.patch
# Patch "configure" & src/Makefile.in to rename the library to "libvmime-zarafa"
patch -p1 < $CWD/patches/name.patch
+# Patch for newer gcc versions (based on tips from the Zarafa forum)
+patch -p1 < $CWD/patches/libvmime_signal.patch
CFLAGS=$SLKCFLAGS \
CXXFLAGS=$SLKCFLAGS \
diff --git a/libraries/libvmime-zarafa/patches/libvmime_signal.patch b/libraries/libvmime-zarafa/patches/libvmime_signal.patch
new file mode 100644
index 000000000000..1ddfabae87fa
--- /dev/null
+++ b/libraries/libvmime-zarafa/patches/libvmime_signal.patch
@@ -0,0 +1,10 @@
+--- libvmime-0.7.1/vmime/platforms/posix/posixChildProcess.hpp 2005-05-25 16:14:54.000000000 -0300
++++ libvmime-0.7.1_patched/vmime/platforms/posix/posixChildProcess.hpp 2011-03-09 01:09:18.000000000 -0300
+@@ -20,6 +20,7 @@
+ #ifndef VMIME_PLATFORMS_POSIX_POSIXCHILDPROCESS_HPP_INCLUDED
+ #define VMIME_PLATFORMS_POSIX_POSIXCHILDPROCESS_HPP_INCLUDED
+
++#include <signal.h>
+
+ #include "vmime/utility/childProcess.hpp"
+