aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorB. Watson <urchlay@slackware.uk>2023-05-15 21:48:20 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-20 11:17:37 +0700
commit44a775dd6faf32f1e5eae9fad84794e26277d8bc (patch)
tree3b99cc02110f0a510a81a6e4ef6d0d559d0f847e
parent3a35a89130b54d913584b3b96121751dbceba595 (diff)
downloadslackbuilds-44a775dd6faf32f1e5eae9fad84794e26277d8bc.tar.xz
python/click-repl: Align with template.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/click-repl/click-repl.SlackBuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/python/click-repl/click-repl.SlackBuild b/python/click-repl/click-repl.SlackBuild
index f47c56d518cd..acb56652ca49 100644
--- a/python/click-repl/click-repl.SlackBuild
+++ b/python/click-repl/click-repl.SlackBuild
@@ -41,15 +41,12 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -64,16 +61,12 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-# Python 2.7 will be droped in the future.
-if $(python2 -c 'import sys' 2>/dev/null); then
- python2 setup.py install --root=$PKG
- else
- python setup.py install --root=$PKG
-fi
+# Python 2.7 will be dropped in the future.
+python2 setup.py install --root=$PKG
# Replacement of python-2.x Python3.x check presence and build if found.
if $(python3 -c 'import sys' 2>/dev/null); then