aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiancarlo Dessi <slack@giand.it>2024-02-23 17:15:26 +0900
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-02-23 16:51:02 +0700
commit0ffa79ee2804281369d319abe31b96c463083b20 (patch)
tree5261db07a628cc5747e646c68a4937179291c32a
parenta72eb184869aff41d7d2589109b9381a1256736a (diff)
downloadslackbuilds-0ffa79ee2804281369d319abe31b96c463083b20.tar.xz
libraries/msgpack-c: Updates.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/msgpack-c/README11
-rw-r--r--libraries/msgpack-c/msgpack-c.SlackBuild6
-rw-r--r--libraries/msgpack-c/msgpack-c.info4
3 files changed, 18 insertions, 3 deletions
diff --git a/libraries/msgpack-c/README b/libraries/msgpack-c/README
index 405eb568b57e..ecad9972cfdc 100644
--- a/libraries/msgpack-c/README
+++ b/libraries/msgpack-c/README
@@ -1,3 +1,14 @@
MessagePack is an efficient binary serialisation format that lets you
exchange data among multiple languages like JSON. msgpack-c is a C and
C++ implementation of MessagePack.
+
+Note: this is the lastest version of msgpack including both C and C++
+implementations. Later versions have separate implementations for these
+languages. This slackbuild is maintained for compatibility with
+some slackbuilds which require msgpack-c.
+
+If you want install a newer version (>=6.0.0) please refer to following
+packages:
+- msgpack-c-cpp for only C++ implementation
+- msgpack-c-c for only C implementation
+(both packages can coexist)
diff --git a/libraries/msgpack-c/msgpack-c.SlackBuild b/libraries/msgpack-c/msgpack-c.SlackBuild
index 938d027d7bc7..92d7d21e4b90 100644
--- a/libraries/msgpack-c/msgpack-c.SlackBuild
+++ b/libraries/msgpack-c/msgpack-c.SlackBuild
@@ -2,6 +2,7 @@
# SlackBuild script for msgpack-c
+# Copyright 2024 Giancarlo Dessi, Cagliari, IT
# Copyright 2021 Ruben Schuller <sb@rbn.im>
# Copyright 2014-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
@@ -30,7 +31,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=msgpack-c
VERSION=${VERSION:-3.3.0}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -81,6 +82,7 @@ find -L . \
-o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+sed -i ./CMakeLists.txt -e "s/(VERSION 2.8.12)/(VERSION 3.5)/g"
mkdir -p build
cd build
@@ -90,6 +92,8 @@ cd build
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=/usr/lib${LIBDIRSUFFIX} \
+ -DMSGPACK_BUILD_TESTS=OFF \
+ -DMSGPACK_BUILD_EXAMPLES=OFF \
..
make install/strip DESTDIR=$PKG
cd ..
diff --git a/libraries/msgpack-c/msgpack-c.info b/libraries/msgpack-c/msgpack-c.info
index a30497cb5e7f..e746c6b2e4f6 100644
--- a/libraries/msgpack-c/msgpack-c.info
+++ b/libraries/msgpack-c/msgpack-c.info
@@ -6,5 +6,5 @@ MD5SUM="e676575d52caae974e579c3d5f0ba6a2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Ruben Schuller"
-EMAIL="sb@rbn.im"
+MAINTAINER="Giancarlo Dessi"
+EMAIL="slack@giand.it"