aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArTourter <artourter@gmail.com>2022-03-05 01:10:10 +0000
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-05 22:41:38 +0700
commit07262d6485ae23d7f6479868c90030d6861db4a2 (patch)
tree2298e6cb1561d68fcdcf2c2f968847899eda666d
parent82d0cbadbee9b81b92f5c545c71a00ccf400061f (diff)
gis/python3-xarray: renamed from python/xarray and updated for version 2022.03.0
This is very much a gis package and is python3 only so rename now before other packages start depending on it. Signed-off-by: ArTourter <artourter@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--gis/python3-xarray/README (renamed from python/xarray/README)0
-rw-r--r--gis/python3-xarray/python3-xarray.SlackBuild (renamed from python/xarray/xarray.SlackBuild)20
-rw-r--r--gis/python3-xarray/python3-xarray.info10
-rw-r--r--gis/python3-xarray/slack-desc19
-rw-r--r--python/xarray/slack-desc19
-rw-r--r--python/xarray/xarray.info10
6 files changed, 40 insertions, 38 deletions
diff --git a/python/xarray/README b/gis/python3-xarray/README
index 9b2f84213827..9b2f84213827 100644
--- a/python/xarray/README
+++ b/gis/python3-xarray/README
diff --git a/python/xarray/xarray.SlackBuild b/gis/python3-xarray/python3-xarray.SlackBuild
index e361a2b3c8bb..b207e37591c9 100644
--- a/python/xarray/xarray.SlackBuild
+++ b/gis/python3-xarray/python3-xarray.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Slackware build script for xarray
+# Slackware build script for python3-xarray
# Copyright 2018-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# Copyright 2022 Gregory J. L. Tourte <artourter@gmail.com>
@@ -25,12 +25,14 @@
cd $(dirname $0) ; CWD=$(pwd)
-PRGNAM=xarray
-VERSION=${VERSION:-0.21.1}
+PRGNAM=python3-xarray
+VERSION=${VERSION:-2022.03.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
+SRCNAM=xarray
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -70,14 +72,14 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python3 setup.py install --root=$PKG
@@ -87,7 +89,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- LICENSE README.rst \
+ CITATION.cff CODE_OF_CONDUCT.md CONTRIBUTING.md HOW_TO_RELEASE.md LICENSE README.rst \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/gis/python3-xarray/python3-xarray.info b/gis/python3-xarray/python3-xarray.info
new file mode 100644
index 000000000000..ef15e83bb572
--- /dev/null
+++ b/gis/python3-xarray/python3-xarray.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-xarray"
+VERSION="2022.03.0"
+HOMEPAGE="http://xarray.pydata.org"
+DOWNLOAD="https://github.com/pydata/xarray/archive/v2022.03.0/xarray-2022.03.0.tar.gz"
+MD5SUM="9150b4ad8373e39f62577d64724a1864"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-pandas"
+MAINTAINER="ArTourter"
+EMAIL="artourter@gmail.com"
diff --git a/gis/python3-xarray/slack-desc b/gis/python3-xarray/slack-desc
new file mode 100644
index 000000000000..80a5ce87506d
--- /dev/null
+++ b/gis/python3-xarray/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-xarray: python3-xarray (N-D labeled arrays and datasets)
+python3-xarray:
+python3-xarray: xarray is an open source project and Python package that aims to
+python3-xarray: bring the labeled data power of pandas to the physical sciences,
+python3-xarray: by providing N-dimensional variants of the core pandas data
+python3-xarray: structures.
+python3-xarray:
+python3-xarray:
+python3-xarray:
+python3-xarray:
+python3-xarray:
diff --git a/python/xarray/slack-desc b/python/xarray/slack-desc
deleted file mode 100644
index 91b420dd1765..000000000000
--- a/python/xarray/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-xarray: xarray (N-D labeled arrays and datasets)
-xarray:
-xarray: xarray is an open source project and Python package that aims to
-xarray: bring the labeled data power of pandas to the physical sciences,
-xarray: by providing N-dimensional variants of the core pandas data
-xarray: structures.
-xarray:
-xarray:
-xarray:
-xarray:
-xarray:
diff --git a/python/xarray/xarray.info b/python/xarray/xarray.info
deleted file mode 100644
index 84687c0cba57..000000000000
--- a/python/xarray/xarray.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="xarray"
-VERSION="0.21.1"
-HOMEPAGE="http://xarray.pydata.org"
-DOWNLOAD="https://github.com/pydata/xarray/archive/v0.21.1/xarray-0.21.1.tar.gz"
-MD5SUM="998612204e0cc47278e4ff63d82147e9"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3-pandas"
-MAINTAINER="ArTourter"
-EMAIL="artourter@gmail.com"