aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-03 06:50:15 +0100
committerRobby Workman <rworkman@slackbuilds.org>2021-05-03 01:49:57 -0500
commiteaa9da6193239c5b0817b9881581dee210e68604 (patch)
treee64d673cc4458e04a6f6662b0bdee329fd034965
parent9c1a13348a3052b8419bdf7d1cb18ac82699855c (diff)
python/python-lhafile: Renamed python2-lhafile.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
-rw-r--r--python/python-lhafile/slack-desc19
-rw-r--r--python/python2-lhafile/README (renamed from python/python-lhafile/README)0
-rw-r--r--python/python2-lhafile/python2-lhafile.SlackBuild (renamed from python/python-lhafile/python-lhafile.SlackBuild)17
-rw-r--r--python/python2-lhafile/python2-lhafile.info (renamed from python/python-lhafile/python-lhafile.info)2
-rw-r--r--python/python2-lhafile/slack-desc19
5 files changed, 29 insertions, 28 deletions
diff --git a/python/python-lhafile/slack-desc b/python/python-lhafile/slack-desc
deleted file mode 100644
index cbf338bb993b..000000000000
--- a/python/python-lhafile/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-lhafile: python-lhafile (Python LHA archive extension)
-python-lhafile:
-python-lhafile: This project is an updated version of the project found
-python-lhafile: at http://trac.neotitans.net/wiki/lhafile.
-python-lhafile: It is primarily used as a component in FS-UAE Launcher to index and
-python-lhafile: extract files from .lha archives. The project consists of a Python
-python-lhafile: package (lhafile) and a C extension for Python (lzhlib).
-python-lhafile:
-python-lhafile: Homepage: http://fengestad.no/python-lhafile/
-python-lhafile:
-python-lhafile:
diff --git a/python/python-lhafile/README b/python/python2-lhafile/README
index ad9fda052527..ad9fda052527 100644
--- a/python/python-lhafile/README
+++ b/python/python2-lhafile/README
diff --git a/python/python-lhafile/python-lhafile.SlackBuild b/python/python2-lhafile/python2-lhafile.SlackBuild
index 6478ac09e705..5e03501a4d9b 100644
--- a/python/python-lhafile/python-lhafile.SlackBuild
+++ b/python/python2-lhafile/python2-lhafile.SlackBuild
@@ -24,14 +24,15 @@
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-PRGNAM=python-lhafile
+PRGNAM=python2-lhafile
+SRCNAM=python-lhafile
VERSION=${VERSION:-0.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -42,8 +43,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -61,9 +62,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -71,7 +72,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-lhafile/python-lhafile.info b/python/python2-lhafile/python2-lhafile.info
index f738f79f27ec..50d571e932fb 100644
--- a/python/python-lhafile/python-lhafile.info
+++ b/python/python2-lhafile/python2-lhafile.info
@@ -1,4 +1,4 @@
-PRGNAM="python-lhafile"
+PRGNAM="python2-lhafile"
VERSION="0.2.1"
HOMEPAGE="http://fengestad.no/python-lhafile/"
DOWNLOAD="http://fengestad.no/python-lhafile/python-lhafile-0.2.1.tar.gz"
diff --git a/python/python2-lhafile/slack-desc b/python/python2-lhafile/slack-desc
new file mode 100644
index 000000000000..b91ec159b0e0
--- /dev/null
+++ b/python/python2-lhafile/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-lhafile: python2-lhafile (Python LHA archive extension)
+python2-lhafile:
+python2-lhafile: This project is an updated version of the project found
+python2-lhafile: at http://trac.neotitans.net/wiki/lhafile.
+python2-lhafile: It is primarily used as a component in FS-UAE Launcher to index and
+python2-lhafile: extract files from .lha archives. The project consists of a Python
+python2-lhafile: package (lhafile) and a C extension for Python (lzhlib).
+python2-lhafile:
+python2-lhafile: Homepage: http://fengestad.no/python2-lhafile/
+python2-lhafile:
+python2-lhafile: