aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThibaut Notteboom <thibaut.notteboom@gmail.com>2023-11-20 09:45:07 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-11-20 09:57:34 +0700
commit6e567cdf5e58de2665e951eb42a934bb772f3dbc (patch)
treeba1f8122bc4a482aa3b586bd813686190ca9e6af
parent35c211247d66e65a790b0a5b0165328bd7f9ee27 (diff)
python/Pyro4: Updated for version 4.82.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/Pyro4/Pyro4.SlackBuild13
-rw-r--r--python/Pyro4/Pyro4.info8
2 files changed, 11 insertions, 10 deletions
diff --git a/python/Pyro4/Pyro4.SlackBuild b/python/Pyro4/Pyro4.SlackBuild
index d107f65c184a..fee4eccdcdc6 100644
--- a/python/Pyro4/Pyro4.SlackBuild
+++ b/python/Pyro4/Pyro4.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for Pyro4
-# Copyright 2012-2019 Thibaut Notteboom, Paris, FRANCE
+# Copyright 2012-2023 Thibaut Notteboom, Paris, FRANCE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=Pyro4
-VERSION=${VERSION:-4.77}
+VERSION=${VERSION:-4.82}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -59,6 +56,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -83,7 +83,8 @@ python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a docs/ examples/ LICENSE PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a docs/ examples/ LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+chmod 644 $PKG/usr/doc/$PRGNAM-$VERSION/*/*/* $PKG/usr/doc/$PRGNAM-$VERSION/docs/source/api/message.rst
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/python/Pyro4/Pyro4.info b/python/Pyro4/Pyro4.info
index adbf9ab2d353..e41c5ed3dd83 100644
--- a/python/Pyro4/Pyro4.info
+++ b/python/Pyro4/Pyro4.info
@@ -1,8 +1,8 @@
PRGNAM="Pyro4"
-VERSION="4.77"
-HOMEPAGE="https://pythonhosted.org/Pyro4/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pyro4/Pyro4-4.77.tar.gz"
-MD5SUM="21f015ae93cf9ea2bbbc418a2267e9fb"
+VERSION="4.82"
+HOMEPAGE="https://github.com/irmen/Pyro4"
+DOWNLOAD="https://github.com/irmen/Pyro4/archive/refs/tags/4.82/Pyro4-4.82.tar.gz"
+MD5SUM="d24c83c7f5859ac54d92d1bc3731c8dc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python-serpent"