aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorfourtysixandtwo <fourtysixandtwo@sliderr.net>2023-11-08 02:52:15 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-11-11 08:08:38 +0700
commit720805d82d9d07ad0548e7feef64602be4c2621f (patch)
tree11c2eaea38dc9f514bd69d73e4ab4d5506af544f
parenta7e0c824c19736f8d6af8520f70731d963e23610 (diff)
downloadslackbuilds-720805d82d9d07ad0548e7feef64602be4c2621f.tar.xz
python/python3-Flask-Login: Updated for version 0.6.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-Flask-Login/python3-Flask-Login.SlackBuild25
-rw-r--r--python/python3-Flask-Login/python3-Flask-Login.info6
2 files changed, 7 insertions, 24 deletions
diff --git a/python/python3-Flask-Login/python3-Flask-Login.SlackBuild b/python/python3-Flask-Login/python3-Flask-Login.SlackBuild
index da87a451c9..87f31f1511 100644
--- a/python/python3-Flask-Login/python3-Flask-Login.SlackBuild
+++ b/python/python3-Flask-Login/python3-Flask-Login.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-Flask-Login
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-Flask-Login
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-0.6.2}
+VERSION=${VERSION:-0.6.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -53,20 +50,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -78,9 +61,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
diff --git a/python/python3-Flask-Login/python3-Flask-Login.info b/python/python3-Flask-Login/python3-Flask-Login.info
index 9d24de1af3..68f7c75338 100644
--- a/python/python3-Flask-Login/python3-Flask-Login.info
+++ b/python/python3-Flask-Login/python3-Flask-Login.info
@@ -1,8 +1,8 @@
PRGNAM="python3-Flask-Login"
-VERSION="0.6.2"
+VERSION="0.6.3"
HOMEPAGE="https://github.com/maxcountryman/flask-login"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-login/Flask-Login-0.6.2.tar.gz"
-MD5SUM="8020b22ad7ec6f17034f90117a520633"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-login/Flask-Login-0.6.3.tar.gz"
+MD5SUM="689564b8b7f3782f0db382b7aa85bbc2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="Flask"