aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitris Zlatanidis <d.zlatanidis@gmail.com>2023-10-31 11:51:56 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-11-04 16:41:34 +0700
commit7147226bfb94e601c4044227f5edc1629a23bb1f (patch)
tree6b1d3bf1592fdb85f81fd5c768f896754a34265d
parent71b031ee2c7d96f4f11c320c01714a765b1c4265 (diff)
downloadslackbuilds-7147226bfb94e601c4044227f5edc1629a23bb1f.tar.xz
network/Free-Cinema: Removed (unused anywhere else).
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/Free-Cinema/Free-Cinema.SlackBuild96
-rw-r--r--network/Free-Cinema/Free-Cinema.info10
-rw-r--r--network/Free-Cinema/README9
-rw-r--r--network/Free-Cinema/doinst.sh3
-rw-r--r--network/Free-Cinema/slack-desc19
5 files changed, 0 insertions, 137 deletions
diff --git a/network/Free-Cinema/Free-Cinema.SlackBuild b/network/Free-Cinema/Free-Cinema.SlackBuild
deleted file mode 100644
index 4ba7dcb3e9..0000000000
--- a/network/Free-Cinema/Free-Cinema.SlackBuild
+++ /dev/null
@@ -1,96 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for Free-Cinema
-
-# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=Free-Cinema
-VERSION=${VERSION:-0.3.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/Free-Cinema/Free-Cinema.info b/network/Free-Cinema/Free-Cinema.info
deleted file mode 100644
index e28d5f76a0..0000000000
--- a/network/Free-Cinema/Free-Cinema.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Free-Cinema"
-VERSION="0.3.0"
-HOMEPAGE="https://pypi.python.org/pypi/Free-Cinema/0.3.0"
-DOWNLOAD="https://pypi.python.org/packages/source/F/Free-Cinema/Free-Cinema-0.3.0.tar.gz"
-MD5SUM="2164bb23782a422015fc89cdaec75c8b"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="wxPython python2-BeautifulSoup4"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/network/Free-Cinema/README b/network/Free-Cinema/README
deleted file mode 100644
index b69f019cb5..0000000000
--- a/network/Free-Cinema/README
+++ /dev/null
@@ -1,9 +0,0 @@
-Search, Download movies via Torrent.
-
-This program is made to browse movies to download from the comfort
-of your desktop. You must have a torrent client to download the video
-files.
-
-After installing run the program by typing "freecinema" without quotes
-and browse to the movie you want, click download, save the torrent
-file from the browser, and open it with your torrent client.
diff --git a/network/Free-Cinema/doinst.sh b/network/Free-Cinema/doinst.sh
deleted file mode 100644
index 5fb28930db..0000000000
--- a/network/Free-Cinema/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/network/Free-Cinema/slack-desc b/network/Free-Cinema/slack-desc
deleted file mode 100644
index bc18a423fe..0000000000
--- a/network/Free-Cinema/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-Free-Cinema: Free-Cinema (Search, Download movies via Torrent)
-Free-Cinema:
-Free-Cinema: This program is made to browse movies to download from the comfort
-Free-Cinema: of your desktop.
-Free-Cinema:
-Free-Cinema: Homepage: https://pypi.python.org/pypi/Free-Cinema/0.3.0
-Free-Cinema:
-Free-Cinema:
-Free-Cinema:
-Free-Cinema:
-Free-Cinema: