aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatteo Bernardini <ponce@slackbuilds.org>2023-10-22 13:21:49 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-10-28 13:11:58 +0700
commitf3dd93f3cbf56f84dd7a2a60eea9d4cc77c72b41 (patch)
treecded6930ecd76b843d2782928405313c0e4c6ec9
parent0ddc5133a4a5ee3879693f0c4b2e1181cd96a50f (diff)
downloadslackbuilds-f3dd93f3cbf56f84dd7a2a60eea9d4cc77c72b41.tar.xz
libraries/unarr: Updated for version 1.1.1.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/unarr/CMakeLists.txt99
-rw-r--r--libraries/unarr/unarr.SlackBuild4
-rw-r--r--libraries/unarr/unarr.info6
3 files changed, 5 insertions, 104 deletions
diff --git a/libraries/unarr/CMakeLists.txt b/libraries/unarr/CMakeLists.txt
deleted file mode 100644
index 1dceae0981..0000000000
--- a/libraries/unarr/CMakeLists.txt
+++ /dev/null
@@ -1,99 +0,0 @@
-cmake_minimum_required(VERSION 2.6)
-project(unarr C)
-
-#Set up api and release version for later use.
-#Increase in major api version indicates api
-#breakage!! For non-breaking changes, use
-#minor api version instead.
-set (UNARR_API_VERSION_MAJOR 1)
-set (UNARR_API_VERSION_MINOR 0)
-
-#set build type to default if unset
-if( NOT CMAKE_BUILD_TYPE )
- set( CMAKE_BUILD_TYPE Release CACHE STRING
- "Choose the type of build, options are: None Debug Release RelWithDebInfo
-MinSizeRel."
- FORCE )
-endif()
-
-find_package(ZLIB)
-find_package(BZip2)
-
-if (UNIX OR MINGW)
- add_compile_options(-fomit-frame-pointer -D_FILE_OFFSET_BITS=64)
-endif (UNIX OR MINGW)
-
-#sources
-
-set (HEADERS common/allocator.h
- common/unarr-imp.h
- rar/rar.h
- rar/lzss.h
- rar/rarvm.h
- lzmasdk/LzmaDec.h
- lzmasdk/Ppmd7.h
- lzmasdk/CpuArch.h
- lzmasdk/Ppmd.h
- lzmasdk/7zTypes.h
- lzmasdk/Ppmd8.h
- lzmasdk/Precomp.h
- _7z/_7z.h
- zip/zip.h
- zip/inflate.h
- tar/tar.h)
-
-set (SOURCES rar/uncompress-rar.c
- rar/huffman-rar.c
- rar/rar.c
- rar/filter-rar.c
- rar/rarvm.c
- rar/parse-rar.c
- _7z/_7z.c
- zip/zip.c
- zip/inflate.c
- zip/parse-zip.c
- zip/uncompress-zip.c
- tar/tar.c
- tar/parse-tar.c
- lzmasdk/Ppmd7.c
- lzmasdk/Ppmd8.c
- lzmasdk/CpuArch.c
- lzmasdk/LzmaDec.c
- lzmasdk/Ppmd7Dec.c
- lzmasdk/Ppmd8Dec.c
- common/custalloc.c
- common/unarr.c
- common/stream.c
- common/conv.c
- common/crc32.c
- )
-
-#(below is edited to process just the shared library)
-
-#build targets
-add_library(unarr SHARED unarr.h ${HEADERS} ${SOURCES})
-#add_library(unarr_static STATIC unarr.h ${HEADERS} ${SOURCES})
-set_target_properties(unarr PROPERTIES VERSION ${UNARR_API_VERSION_MAJOR}.${UNARR_API_VERSION_MINOR} SOVERSION ${UNARR_API_VERSION_MAJOR})
-#set_target_properties(unarr_static PROPERTIES OUTPUT_NAME unarr VERSION ${UNARR_API_VERSION_MAJOR}.${UNARR_API_VERSION_MINOR} SOVERSION ${UNARR_API_VERSION_MAJOR})
-
-#library detection macros
-
-if (ZLIB_FOUND)
- include_directories(${ZLIB_INCLUDE_DIRS})
- target_link_libraries(unarr ${ZLIB_LIBRARIES})
-# target_link_libraries(unarr_static ${ZLIB_LIBRARIES})
- add_definitions(-DHAVE_ZLIB)
-endif(ZLIB_FOUND)
-
-if (BZIP2_FOUND)
- include_directories(${BZIP_INCLUDE_DIRS})
- target_link_libraries (unarr ${BZIP2_LIBRARIES})
-# target_link_libraries (unarr_static ${BZIP2_LIBRARIES})
- add_definitions(-DHAVE_BZIP2)
-endif (BZIP2_FOUND)
-
-#make install targets
-
-install(TARGETS unarr DESTINATION lib@LIBDIRSUFFIX@)
-#install(TARGETS unarr_static DESTINATION lib@LIBDIRSUFFIX@)
-install(FILES unarr.h DESTINATION include)
diff --git a/libraries/unarr/unarr.SlackBuild b/libraries/unarr/unarr.SlackBuild
index a630c7da3f..160ee1a82b 100644
--- a/libraries/unarr/unarr.SlackBuild
+++ b/libraries/unarr/unarr.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for unarr
-# Copyright 2016-2018 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# Copyright 2016-2023 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=unarr
-VERSION=${VERSION:-1.0.1}
+VERSION=${VERSION:-1.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
diff --git a/libraries/unarr/unarr.info b/libraries/unarr/unarr.info
index 2f59c69193..b18a386f49 100644
--- a/libraries/unarr/unarr.info
+++ b/libraries/unarr/unarr.info
@@ -1,8 +1,8 @@
PRGNAM="unarr"
-VERSION="1.0.1"
+VERSION="1.1.1"
HOMEPAGE="https://github.com/selmf/unarr"
-DOWNLOAD="https://github.com/selmf/unarr/releases/download/v1.0.1/unarr-1.0.1.tar.xz"
-MD5SUM="995a3de03b8a083c342e7d4b5a44fd52"
+DOWNLOAD="https://github.com/selmf/unarr/releases/download/v1.1.1/unarr-1.1.1.tar.xz"
+MD5SUM="e3848dba8c655230c105b574a533a825"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""