aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorfourtysixandtwo <fourtysixandtwo@sliderr.net>2023-10-08 10:14:41 -0600
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-10-14 10:32:30 +0700
commit4997ab55349a84470f2fccf494dc51c61f0a42e2 (patch)
tree5a5029c11d857b47b6509d52403f7910a93ea8dc
parentb7a2068b0d6e2657ffb5d29a0bc5f5822e0db84b (diff)
downloadslackbuilds-4997ab55349a84470f2fccf494dc51c61f0a42e2.tar.xz
python/python3-flask-paginate: Updated for version 2023.10.8.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-flask-paginate/python3-flask-paginate.SlackBuild25
-rw-r--r--python/python3-flask-paginate/python3-flask-paginate.info6
2 files changed, 7 insertions, 24 deletions
diff --git a/python/python3-flask-paginate/python3-flask-paginate.SlackBuild b/python/python3-flask-paginate/python3-flask-paginate.SlackBuild
index 48f5be76be..3e97a0aa71 100644
--- a/python/python3-flask-paginate/python3-flask-paginate.SlackBuild
+++ b/python/python3-flask-paginate/python3-flask-paginate.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-flask-paginate
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-flask-paginate
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-2022.1.8}
+VERSION=${VERSION:-2023.10.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -53,20 +50,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -78,9 +61,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
diff --git a/python/python3-flask-paginate/python3-flask-paginate.info b/python/python3-flask-paginate/python3-flask-paginate.info
index 1d160c9c6c..68952ea273 100644
--- a/python/python3-flask-paginate/python3-flask-paginate.info
+++ b/python/python3-flask-paginate/python3-flask-paginate.info
@@ -1,8 +1,8 @@
PRGNAM="python3-flask-paginate"
-VERSION="2022.1.8"
+VERSION="2023.10.8"
HOMEPAGE="https://github.com/lixxu/flask-paginate"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-paginate/flask-paginate-2022.1.8.tar.gz"
-MD5SUM="43026190ffa68e710b13b0f3649ce1a6"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-paginate/flask-paginate-2023.10.8.tar.gz"
+MD5SUM="307d7143810914897585b2a9e373f1df"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="Flask"