aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorB. Watson <yalhcru@gmail.com>2022-02-20 11:29:11 -0500
committerRobby Workman <rworkman@slackbuilds.org>2022-02-21 14:34:27 -0600
commit346204ffef4d87d6631e055bac490d7a367660f2 (patch)
tree9b05bd0f93e6beecc9dcb5cd321449af67dc977c
parentb0427090c84e9b6b5fff9fb7aa916e9c9d46f3ca (diff)
games/briquolo: Fix 15.0 build.
Signed-off-by: B. Watson <yalhcru@gmail.com>
-rw-r--r--games/briquolo/briquolo.SlackBuild32
1 files changed, 20 insertions, 12 deletions
diff --git a/games/briquolo/briquolo.SlackBuild b/games/briquolo/briquolo.SlackBuild
index 2d28673072c0..30cf5ac4440c 100644
--- a/games/briquolo/briquolo.SlackBuild
+++ b/games/briquolo/briquolo.SlackBuild
@@ -8,25 +8,27 @@
# Based on http://slackbuilds.org/template.SlackBuild
+# 20220220 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - fix build on 15.0.
+# - fix .desktop file (it had TryExec=tuxkart... uhhh).
+# - binary in /usr/games.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=briquolo
VERSION=${VERSION:-0.5.7}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) export ARCH=i486 ;;
+ i?86) export ARCH=i586 ;;
arm*) export ARCH=arm ;;
*) export ARCH=$( uname -m ) ;;
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -36,8 +38,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -58,6 +60,7 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xjvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
+
#Before building, we have to apply a lot of patches. Developer has left his application :(
#Fix building with "newer" gcc versions (> 4.3)
patch -p1 < $CWD/patches/gcc-fixes.patch
@@ -69,31 +72,36 @@ patch -p1 < $CWD/patches/fix_ati_crash.patch
patch -p1 < $CWD/patches/desktop-entry.patch
#Done! Lets do the rest in standard way now.
chown -R root:root .
+
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} \+
CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS -std=gnu++98" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
+ --bindir=/usr/games \
--build=$ARCH-slackware-linux
# Workaround some stupid Makefile problems.
sed -i -e's|icondir = $(DESTDIR)|icondir = |' desktop/Makefile
mkdir -p $PKG/usr/share/applications
+sed -i -e '/^\(TryExec\|Encoding\)/d' \
+ -e 's,/usr/bin,/usr/games,' \
+ desktop/$PRGNAM.desktop
make
-make install DESTDIR=$PKG
+make install-strip DESTDIR=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL DejaVuSans.ttf-LICENSE README \
+ AUTHORS COPYING ChangeLog DejaVuSans.ttf-LICENSE README \
$PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKG/install