aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorisaackwy <isaacyu@protonmail.com>2024-02-19 16:18:20 -0800
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-02-23 10:14:54 +0700
commit6aa6ff22644e62377bc7c0e7f5b65a6676d2dc80 (patch)
treeaead2b450146d568a8365d43b5b829b4f1059896
parent1c4ca692aef1b40f7b1c4bc781ea223eb2c62a7e (diff)
python/python3-pythran: Update for 0.15.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-pythran/python3-pythran.SlackBuild18
-rw-r--r--python/python3-pythran/python3-pythran.info8
2 files changed, 14 insertions, 12 deletions
diff --git a/python/python3-pythran/python3-pythran.SlackBuild b/python/python3-pythran/python3-pythran.SlackBuild
index 34f0442f18c71..6c8ffe97abf14 100644
--- a/python/python3-pythran/python3-pythran.SlackBuild
+++ b/python/python3-pythran/python3-pythran.SlackBuild
@@ -1,7 +1,8 @@
#!/bin/bash
# Slackware build script for python3-pythran
-# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
+#
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pythran
-VERSION=${VERSION:-0.13.1}
+VERSION=${VERSION:-0.15.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -48,17 +49,14 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+# Only LIBDIRSUFFIX is used within the SlackBuild
if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
- SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
@@ -77,7 +75,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# Needs newer setuptools
+export PYTHONPATH=/opt/python3.9/site-packages/
+
+python3 -m build --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -86,7 +88,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
rm -r $PKG/usr/lib$LIBDIRSUFFIX/python*/site-packages/pythran/{boost,xsimd}
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS Changelog LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS Changelog README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-pythran/python3-pythran.info b/python/python3-pythran/python3-pythran.info
index e2235ccf30fe9..b57720bc0c2b9 100644
--- a/python/python3-pythran/python3-pythran.info
+++ b/python/python3-pythran/python3-pythran.info
@@ -1,10 +1,10 @@
PRGNAM="python3-pythran"
-VERSION="0.13.1"
+VERSION="0.15.0"
HOMEPAGE="https://pythran.readthedocs.io/en/latest/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pythran/pythran-0.13.1.tar.gz"
-MD5SUM="3090288af50566af75cb058d1878aaad"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pythran/pythran-0.15.0.tar.gz"
+MD5SUM="cc6fa05e583733182d06d2e41e03cc10"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-beniget python3-numpy xsimd python3-pytest-runner"
+REQUIRES="python3-beniget python3-numpy python3-setuptools-opt xsimd"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu@protonmail.com"