aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Verbovetsky <alik@ejik.org>2023-06-22 23:08:19 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-06-22 23:08:19 +0700
commit6ba98e2001995c2d20f9b5203d01206d9270c203 (patch)
tree8dd607870b784c2cb94e3afe2414d0dc986b5743
parentab68b5de51066bccee9687b81b6a4ac43e5b17bf (diff)
office/krop: Updated for version 0.6.1_e96d42b.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--office/krop/README15
-rw-r--r--office/krop/krop.SlackBuild15
-rw-r--r--office/krop/krop.info8
-rw-r--r--office/krop/slack-desc8
4 files changed, 26 insertions, 20 deletions
diff --git a/office/krop/README b/office/krop/README
index 780083460dc44..36345b8eb4c30 100644
--- a/office/krop/README
+++ b/office/krop/README
@@ -1,7 +1,16 @@
-Krop is a simple graphical tool to crop the pages of PDF files. It is
-written in Python and relies on PyQt, python-poppler-qt4, and PyPDF for
-its functionality. It features automatic margin cropping.
+krop is a simple graphical tool to crop the pages of PDF files.
+
+It is written in Python and relies on python-poppler-qt5 or PyMuPDF for
+rendering, and pypdf/PyPDF2 or pikepdf or PyMuPDF for cropping. It
+features automatic margin cropping.
Krop can automatically split pages into subpages to fit the limited
screen size of devices such as eReaders. This is particularly useful, if
your eReader does not support convenient scrolling.
+
+This script has no build dependencies.
+
+Two runtime dependencies to be choosen from the following options:
+* python-poppler-qt5 or PyMuPDF
+* pypdf (version > 3) or PyPDF2 or pikepdf or PyMuPDF
+They are autodetected or set manually using options.
diff --git a/office/krop/krop.SlackBuild b/office/krop/krop.SlackBuild
index d1dd7f527c704..beeb0c1f6e99b 100644
--- a/office/krop/krop.SlackBuild
+++ b/office/krop/krop.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for krop
-# Copyright 2018-2020, Alexander Verbovetsky, Moscow, Russia
+# Copyright 2018-2023, Alexander Verbovetsky, Moscow, Russia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=krop
-VERSION=${VERSION:-0.6.0}
+VERSION=${VERSION:-0.6.1_e96d42b}
+COMMIT="e96d42b2f1ab4317efe37cab498b708663bc104c"
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -69,9 +67,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$COMMIT
+tar xvf $CWD/$PRGNAM-$COMMIT.tar.gz
+cd $PRGNAM-$COMMIT
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -82,7 +80,6 @@ find -L . \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
python3 setup.py install --root=$PKG
-sed -i "s|krop==0.6.0|krop|g" $PKG/usr/bin/krop
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/office/krop/krop.info b/office/krop/krop.info
index f0c0393ba45ba..603dbbc2177f4 100644
--- a/office/krop/krop.info
+++ b/office/krop/krop.info
@@ -1,10 +1,10 @@
PRGNAM="krop"
-VERSION="0.6.0"
+VERSION="0.6.1_e96d42b"
HOMEPAGE="http://arminstraub.com/computer/krop"
-DOWNLOAD="https://github.com/arminstraub/krop/archive/v0.6.0/krop-0.6.0.tar.gz"
-MD5SUM="8bf9e9d64a4f7b749980a14dc699f96a"
+DOWNLOAD="https://github.com/arminstraub/krop/archive/e96d42b/krop-e96d42b2f1ab4317efe37cab498b708663bc104c.tar.gz"
+MD5SUM="9ddb0caa00585882e4d3b081bf5b3b4f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-poppler-qt5 PyPDF2"
+REQUIRES="%README% python-poppler-qt5 PyPDF2"
MAINTAINER="Alexander Verbovetsky"
EMAIL="alik@ejik.org"
diff --git a/office/krop/slack-desc b/office/krop/slack-desc
index 70a796693267c..16e3c34354fc0 100644
--- a/office/krop/slack-desc
+++ b/office/krop/slack-desc
@@ -8,12 +8,12 @@
|-----handy-ruler------------------------------------------------------|
krop: krop (a tool to crop pdf files)
krop:
-krop: Krop is a simple graphical tool to crop the pages of PDF files. It is
-krop: written in Python and relies on PyQt, python-poppler-qt4, and PyPDF
-krop: for its functionality. It features automatic margin cropping.
+krop: krop is a simple graphical tool to crop the pages of PDF files. It is
+krop: written in Python and relies on python-poppler-qt5 or PyMuPDF for
+krop: rendering, and pypdf/PyPDF2 or pikepdf or PyMuPDF for cropping. It
+krop: features automatic margin cropping.
krop:
krop:
krop: Homepage: http://arminstraub.com/computer/krop
krop:
krop:
-krop: