aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorB. Watson <urchlay@slackware.uk>2023-09-04 15:27:19 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-09 10:14:21 +0700
commit13375d742ba719fc7ea59bf7298b136f4a2adb17 (patch)
tree8e2186288149e6da5efd83eab73e777b313ee9f9
parent7137eab3a3a6dcfcfac75578e107a6489886beac (diff)
network/yt-dlp: Fix requirements.txt.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/yt-dlp/yt-dlp.SlackBuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/network/yt-dlp/yt-dlp.SlackBuild b/network/yt-dlp/yt-dlp.SlackBuild
index 39d313690fd23..1434d65818eb1 100644
--- a/network/yt-dlp/yt-dlp.SlackBuild
+++ b/network/yt-dlp/yt-dlp.SlackBuild
@@ -12,6 +12,7 @@
# for clipgrab, haruna, xdman, ytfzf, and an optional dependency for
# pipe-viewer, it has to exist on SBo.
+# 20230904 bkw: BUILD=2, silence complaints from 'pip3 check'
# 20230711 bkw: updated for v2023.07.06
# 20230623 bkw: updated for v2023.06.22, added version check
# 20230402 bkw: updated for v2023.03.04
@@ -22,7 +23,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=yt-dlp
VERSION=${VERSION:-2023.07.06}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,6 +83,15 @@ sed -i -e "s,share/doc/yt_dlp,doc/$PRGNAM-$VERSION," \
-e "s,share/man,man," \
setup.py
+# 20230904 bkw: mixed signals from upstream. The README.md documents
+# various python modules as optional, but some of them are listed in
+# requirements.txt, meaning 'pip3 check' treats them as required,
+# even though yt-dlp itself works fine without them. The fix is to
+# remove the optional stuff from requirements.txt, to make it agreee
+# with README.md. My own README documents these already. brotli and
+# certifi are included in Slackware.
+sed -i '/\(mutagen\|pycryptodomex\|websockets\)/d' requirements.txt
+
# if anyone's wondering, there's no python2 support.
python3 setup.py install --root=$PKG