aboutsummaryrefslogtreecommitdiff
path: root/tests/unit/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/unit/meson.build')
-rw-r--r--tests/unit/meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/tests/unit/meson.build b/tests/unit/meson.build
index 64a5e7bfde..3a51759ebc 100644
--- a/tests/unit/meson.build
+++ b/tests/unit/meson.build
@@ -106,7 +106,7 @@ if have_block
if 'CONFIG_POSIX' in config_host
tests += {'test-image-locking': [testblock]}
endif
- if 'CONFIG_REPLICATION' in config_host
+ if config_host_data.get('CONFIG_REPLICATION')
tests += {'test-replication': [testblock]}
endif
if nettle.found() or gcrypt.found()
@@ -149,9 +149,7 @@ if have_system
endif
endif
-if 'CONFIG_TSAN' not in config_host and \
- 'CONFIG_GUEST_AGENT' in config_host and \
- 'CONFIG_LINUX' in config_host
+if have_ga and targetos == 'linux' and 'CONFIG_TSAN' not in config_host
tests += {'test-qga': ['../qtest/libqtest.c']}
test_deps += {'test-qga': qga}
endif