aboutsummaryrefslogtreecommitdiff
path: root/tests/unit/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/unit/meson.build')
-rw-r--r--tests/unit/meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/tests/unit/meson.build b/tests/unit/meson.build
index b3bc2109da..3e0504dd21 100644
--- a/tests/unit/meson.build
+++ b/tests/unit/meson.build
@@ -83,8 +83,8 @@ if have_block
'test-crypto-afsplit': [io],
'test-crypto-block': [io],
}
- if 'CONFIG_GNUTLS' in config_host and \
- 'CONFIG_TASN1' in config_host and \
+ if gnutls.found() and \
+ tasn1.found() and \
'CONFIG_POSIX' in config_host
tests += {
'test-crypto-tlscredsx509': ['crypto-tls-x509-helpers.c', 'pkix_asn1_tab.c',
@@ -94,10 +94,10 @@ if have_block
'test-io-channel-tls': ['io-channel-helpers.c', 'crypto-tls-x509-helpers.c', 'pkix_asn1_tab.c',
tasn1, io, crypto, gnutls]}
endif
- if 'CONFIG_AUTH_PAM' in config_host
+ if pam.found()
tests += {'test-authz-pam': [authz]}
endif
- if 'CONFIG_QEMU_PRIVATE_XTS' in config_host
+ if xts == 'private'
tests += {'test-crypto-xts': [crypto, io]}
endif
if 'CONFIG_POSIX' in config_host
@@ -106,7 +106,7 @@ if have_block
if 'CONFIG_REPLICATION' in config_host
tests += {'test-replication': [testblock]}
endif
- if 'CONFIG_NETTLE' in config_host or 'CONFIG_GCRYPT' in config_host
+ if nettle.found() or gcrypt.found()
tests += {'test-crypto-pbkdf': [io]}
endif
if 'CONFIG_EPOLL_CREATE1' in config_host