aboutsummaryrefslogtreecommitdiff
path: root/tests/qtest/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/qtest/meson.build')
-rw-r--r--tests/qtest/meson.build17
1 files changed, 12 insertions, 5 deletions
diff --git a/tests/qtest/meson.build b/tests/qtest/meson.build
index e97616d327..222e1892fb 100644
--- a/tests/qtest/meson.build
+++ b/tests/qtest/meson.build
@@ -73,11 +73,14 @@ qtests_i386 = \
(config_all_devices.has_key('CONFIG_ESP_PCI') ? ['am53c974-test'] : []) + \
(config_host.has_key('CONFIG_POSIX') and \
config_all_devices.has_key('CONFIG_ACPI_ERST') ? ['erst-test'] : []) + \
- (config_all_devices.has_key('CONFIG_VIRTIO_NET') and \
+ (config_all_devices.has_key('CONFIG_PCIE_PORT') and \
+ config_all_devices.has_key('CONFIG_VIRTIO_NET') and \
config_all_devices.has_key('CONFIG_Q35') and \
config_all_devices.has_key('CONFIG_VIRTIO_PCI') and \
slirp.found() ? ['virtio-net-failover'] : []) + \
- (unpack_edk2_blobs ? ['bios-tables-test'] : []) + \
+ (unpack_edk2_blobs and \
+ config_all_devices.has_key('CONFIG_HPET') and \
+ config_all_devices.has_key('CONFIG_PARALLEL') ? ['bios-tables-test'] : []) + \
qtests_pci + \
qtests_cxl + \
['fdc-test',
@@ -196,11 +199,11 @@ qtests_arm = \
(config_all_devices.has_key('CONFIG_PFLASH_CFI02') ? ['pflash-cfi02-test'] : []) + \
(config_all_devices.has_key('CONFIG_ASPEED_SOC') ? qtests_aspeed : []) + \
(config_all_devices.has_key('CONFIG_NPCM7XX') ? qtests_npcm7xx : []) + \
+ (config_all_devices.has_key('CONFIG_GENERIC_LOADER') ? ['hexloader-test'] : []) + \
['arm-cpu-features',
'microbit-test',
'test-arm-mptimer',
- 'boot-serial-test',
- 'hexloader-test']
+ 'boot-serial-test']
# TODO: once aarch64 TCG is fixed on ARM 32 bit host, make bios-tables-test unconditional
qtests_aarch64 = \
@@ -254,10 +257,14 @@ qos_test_ss.add(
'virtio-net-test.c',
'virtio-rng-test.c',
'virtio-scsi-test.c',
- 'virtio-serial-test.c',
'virtio-iommu-test.c',
'vmxnet3-test.c',
)
+
+if config_all_devices.has_key('CONFIG_VIRTIO_SERIAL')
+ qos_test_ss.add(files('virtio-serial-test.c'))
+endif
+
if config_host.has_key('CONFIG_POSIX')
qos_test_ss.add(files('e1000e-test.c'))
endif