aboutsummaryrefslogtreecommitdiff
path: root/tests/qtest/fuzz/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/qtest/fuzz/meson.build')
-rw-r--r--tests/qtest/fuzz/meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/qtest/fuzz/meson.build b/tests/qtest/fuzz/meson.build
index 8af6848cd5..189901d4a2 100644
--- a/tests/qtest/fuzz/meson.build
+++ b/tests/qtest/fuzz/meson.build
@@ -1,3 +1,7 @@
+if not get_option('fuzzing')
+ subdir_done()
+endif
+
specific_fuzz_ss.add(files('fuzz.c', 'fork_fuzz.c', 'qos_fuzz.c',
'qtest_wrappers.c'), qos)
@@ -9,7 +13,7 @@ specific_fuzz_ss.add(when: 'CONFIG_VIRTIO_BLK', if_true: files('virtio_blk_fuzz.
specific_fuzz_ss.add(files('generic_fuzz.c'))
fork_fuzz = declare_dependency(
- link_args: config_host['FUZZ_EXE_LDFLAGS'].split() +
+ link_args: fuzz_exe_ldflags +
['-Wl,-wrap,qtest_inb',
'-Wl,-wrap,qtest_inw',
'-Wl,-wrap,qtest_inl',