aboutsummaryrefslogtreecommitdiff
path: root/tests/qemu-iotests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/qemu-iotests/meson.build')
-rw-r--r--tests/qemu-iotests/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/qemu-iotests/meson.build b/tests/qemu-iotests/meson.build
new file mode 100644
index 0000000000..3de09fb8fa
--- /dev/null
+++ b/tests/qemu-iotests/meson.build
@@ -0,0 +1,10 @@
+if 'CONFIG_LINUX' in config_host
+ socket_scm_helper = executable('socket_scm_helper', 'socket_scm_helper.c',
+ build_by_default: false)
+else
+ socket_scm_helper = []
+endif
+test('qemu-iotests', sh, args: [files('../check-block.sh')],
+ depends: [qemu_block_tools, emulators, socket_scm_helper],
+ suite: 'block', timeout: 10000)
+