aboutsummaryrefslogtreecommitdiff
path: root/target/xtensa/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'target/xtensa/meson.build')
-rw-r--r--target/xtensa/meson.build13
1 files changed, 4 insertions, 9 deletions
diff --git a/target/xtensa/meson.build b/target/xtensa/meson.build
index dd750a977e..7c4efa6c62 100644
--- a/target/xtensa/meson.build
+++ b/target/xtensa/meson.build
@@ -1,14 +1,9 @@
xtensa_ss = ss.source_set()
+
+xtensa_cores = run_command('sh', '-c', 'cd $MESON_SOURCE_ROOT/$MESON_SUBDIR ; ls -1 core-*.c')
+xtensa_ss.add(files(xtensa_cores.stdout().strip().split('\n')))
+
xtensa_ss.add(files(
- 'core-dc232b.c',
- 'core-dc233c.c',
- 'core-de212.c',
- 'core-de233_fpu.c',
- 'core-dsp3400.c',
- 'core-fsf.c',
- 'core-sample_controller.c',
- 'core-test_kc705_be.c',
- 'core-test_mmuhifi_c3.c',
'cpu.c',
'exc_helper.c',
'fpu_helper.c',