aboutsummaryrefslogtreecommitdiff
path: root/target/sparc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'target/sparc/meson.build')
-rw-r--r--target/sparc/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/sparc/meson.build b/target/sparc/meson.build
new file mode 100644
index 0000000000..a3638b9503
--- /dev/null
+++ b/target/sparc/meson.build
@@ -0,0 +1,23 @@
+sparc_ss = ss.source_set()
+sparc_ss.add(files(
+ 'cc_helper.c',
+ 'cpu.c',
+ 'fop_helper.c',
+ 'gdbstub.c',
+ 'helper.c',
+ 'ldst_helper.c',
+ 'mmu_helper.c',
+ 'translate.c',
+ 'win_helper.c',
+))
+sparc_ss.add(when: 'TARGET_SPARC', if_true: files('int32_helper.c'))
+sparc_ss.add(when: 'TARGET_SPARC64', if_true: files('int64_helper.c', 'vis_helper.c'))
+
+sparc_softmmu_ss = ss.source_set()
+sparc_softmmu_ss.add(files(
+ 'machine.c',
+ 'monitor.c',
+))
+
+target_arch += {'sparc': sparc_ss}
+target_softmmu_arch += {'sparc': sparc_softmmu_ss}