aboutsummaryrefslogtreecommitdiff
path: root/target/ppc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'target/ppc/meson.build')
-rw-r--r--target/ppc/meson.build8
1 files changed, 5 insertions, 3 deletions
diff --git a/target/ppc/meson.build b/target/ppc/meson.build
index a4f18ff414..b85f295703 100644
--- a/target/ppc/meson.build
+++ b/target/ppc/meson.build
@@ -37,11 +37,13 @@ ppc_softmmu_ss.add(files(
'arch_dump.c',
'machine.c',
'mmu-hash32.c',
- 'mmu_helper.c',
+ 'mmu_common.c',
'monitor.c',
))
-ppc_softmmu_ss.add(when: 'CONFIG_TCG', if_false: files(
- 'tcg-stub.c'
+ppc_softmmu_ss.add(when: 'CONFIG_TCG', if_true: files(
+ 'mmu_helper.c',
+), if_false: files(
+ 'tcg-stub.c',
))
ppc_softmmu_ss.add(when: 'TARGET_PPC64', if_true: files(