aboutsummaryrefslogtreecommitdiff
path: root/target/mips/tcg/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'target/mips/tcg/meson.build')
-rw-r--r--target/mips/tcg/meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/mips/tcg/meson.build b/target/mips/tcg/meson.build
index bf4001e574..8f6f7508b6 100644
--- a/target/mips/tcg/meson.build
+++ b/target/mips/tcg/meson.build
@@ -1,8 +1,8 @@
gen = [
- decodetree.process('mips32r6.decode', extra_args: '--static-decode=decode_mips32r6'),
- decodetree.process('mips64r6.decode', extra_args: '--static-decode=decode_mips64r6'),
+ decodetree.process('rel6.decode', extra_args: ['--decode=decode_isa_rel6']),
decodetree.process('msa.decode', extra_args: '--decode=decode_ase_msa'),
decodetree.process('tx79.decode', extra_args: '--static-decode=decode_tx79'),
+ decodetree.process('vr54xx.decode', extra_args: '--decode=decode_ext_vr54xx'),
]
mips_ss.add(gen)
@@ -19,6 +19,8 @@ mips_ss.add(files(
'translate.c',
'translate_addr_const.c',
'txx9_translate.c',
+ 'vr54xx_helper.c',
+ 'vr54xx_translate.c',
))
mips_ss.add(when: 'TARGET_MIPS64', if_true: files(
'tx79_translate.c',