aboutsummaryrefslogtreecommitdiff
path: root/target/mips/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'target/mips/meson.build')
-rw-r--r--target/mips/meson.build31
1 files changed, 0 insertions, 31 deletions
diff --git a/target/mips/meson.build b/target/mips/meson.build
index e08077bfc1..2407a05d4c 100644
--- a/target/mips/meson.build
+++ b/target/mips/meson.build
@@ -1,11 +1,3 @@
-gen = [
- decodetree.process('mips32r6.decode', extra_args: '--static-decode=decode_mips32r6'),
- decodetree.process('mips64r6.decode', extra_args: '--static-decode=decode_mips64r6'),
- decodetree.process('msa32.decode', extra_args: '--static-decode=decode_msa32'),
- decodetree.process('msa64.decode', extra_args: '--static-decode=decode_msa64'),
- decodetree.process('tx79.decode', extra_args: '--static-decode=decode_tx79'),
-]
-
mips_user_ss = ss.source_set()
mips_softmmu_ss = ss.source_set()
mips_ss = ss.source_set()
@@ -20,35 +12,12 @@ if have_system
subdir('sysemu')
endif
-mips_tcg_ss = ss.source_set()
-mips_tcg_ss.add(gen)
-mips_tcg_ss.add(files(
- 'dsp_helper.c',
- 'exception.c',
- 'fpu_helper.c',
- 'ldst_helper.c',
- 'lmmi_helper.c',
- 'msa_helper.c',
- 'msa_translate.c',
- 'op_helper.c',
- 'rel6_translate.c',
- 'translate.c',
- 'translate_addr_const.c',
- 'txx9_translate.c',
-))
-mips_tcg_ss.add(when: 'TARGET_MIPS64', if_true: files(
- 'tx79_translate.c',
-), if_false: files(
- 'mxu_translate.c',
-))
if 'CONFIG_TCG' in config_all
subdir('tcg')
endif
mips_ss.add(when: 'CONFIG_KVM', if_true: files('kvm.c'))
-mips_ss.add_all(when: 'CONFIG_TCG', if_true: [mips_tcg_ss])
-
target_arch += {'mips': mips_ss}
target_softmmu_arch += {'mips': mips_softmmu_ss}
target_user_arch += {'mips': mips_user_ss}