aboutsummaryrefslogtreecommitdiff
path: root/target/alpha/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'target/alpha/meson.build')
-rw-r--r--target/alpha/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/alpha/meson.build b/target/alpha/meson.build
new file mode 100644
index 0000000000..1aec55abb4
--- /dev/null
+++ b/target/alpha/meson.build
@@ -0,0 +1,18 @@
+alpha_ss = ss.source_set()
+alpha_ss.add(files(
+ 'cpu.c',
+ 'fpu_helper.c',
+ 'gdbstub.c',
+ 'helper.c',
+ 'int_helper.c',
+ 'mem_helper.c',
+ 'sys_helper.c',
+ 'translate.c',
+ 'vax_helper.c',
+))
+
+alpha_softmmu_ss = ss.source_set()
+alpha_softmmu_ss.add(files('machine.c'))
+
+target_arch += {'alpha': alpha_ss}
+target_softmmu_arch += {'alpha': alpha_softmmu_ss}