aboutsummaryrefslogtreecommitdiff
path: root/system/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'system/meson.build')
-rw-r--r--system/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/system/meson.build b/system/meson.build
index 3a64dd89de..0632a3daa8 100644
--- a/system/meson.build
+++ b/system/meson.build
@@ -33,4 +33,6 @@ endif
system_ss.add(when: seccomp, if_true: files('qemu-seccomp.c'))
system_ss.add(when: fdt, if_true: files('device_tree.c'))
-system_ss.add(when: 'CONFIG_LINUX', if_true: files('async-teardown.c'))
+if targetos == 'linux'
+ system_ss.add('async-teardown.c')
+endif