aboutsummaryrefslogtreecommitdiff
path: root/storage-daemon/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'storage-daemon/meson.build')
-rw-r--r--storage-daemon/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/storage-daemon/meson.build b/storage-daemon/meson.build
index 35f8949924..0409acc3f5 100644
--- a/storage-daemon/meson.build
+++ b/storage-daemon/meson.build
@@ -1 +1,14 @@
+qsd_ss = ss.source_set()
+qsd_ss.add(files('qemu-storage-daemon.c'))
+qsd_ss.add(block, chardev, qmp, qom, qemuutil)
+qsd_ss.add_all(blockdev_ss)
+
subdir('qapi')
+
+if have_tools
+ qsd_ss = qsd_ss.apply(config_host, strict: false)
+ executable('qemu-storage-daemon',
+ qsd_ss.sources(),
+ dependencies: qsd_ss.dependencies(),
+ install: true)
+endif