aboutsummaryrefslogtreecommitdiff
path: root/qom/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'qom/meson.build')
-rw-r--r--qom/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/qom/meson.build b/qom/meson.build
new file mode 100644
index 0000000000..a1cd03c82c
--- /dev/null
+++ b/qom/meson.build
@@ -0,0 +1,18 @@
+qom_ss = ss.source_set()
+qom_ss.add(genh)
+qom_ss.add(files(
+ 'container.c',
+ 'object.c',
+ 'object_interfaces.c',
+ 'qom-qobject.c',
+))
+
+qmp_ss.add(files('qom-qmp-cmds.c'))
+softmmu_ss.add(files('qom-hmp-cmds.c'))
+
+qom_ss = qom_ss.apply(config_host, strict: false)
+libqom = static_library('qom', qom_ss.sources() + genh,
+ dependencies: [qom_ss.dependencies()],
+ name_suffix: 'fa')
+
+qom = declare_dependency(link_whole: libqom)