aboutsummaryrefslogtreecommitdiff
path: root/qga/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'qga/meson.build')
-rw-r--r--qga/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/qga/meson.build b/qga/meson.build
index 33f6db2865..2b91261427 100644
--- a/qga/meson.build
+++ b/qga/meson.build
@@ -44,6 +44,7 @@ qga = executable('qemu-ga', qga_ss.sources(),
link_args: config_host['LIBS_QGA'].split(),
dependencies: [qemuutil, libudev],
install: true)
+all_qga = [qga]
if targetos == 'windows'
if 'CONFIG_QGA_VSS' in config_host
@@ -72,6 +73,9 @@ if targetos == 'windows'
config_host['QEMU_GA_MSI_WITH_VSS'].split(),
config_host['QEMU_GA_MSI_MINGW_DLL_PATH'].split(),
])
+ all_qga += [qga_msi]
alias_target('msi', qga_msi)
endif
endif
+
+alias_target('qemu-ga', all_qga)