aboutsummaryrefslogtreecommitdiff
path: root/pc-bios/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'pc-bios/meson.build')
-rw-r--r--pc-bios/meson.build13
1 files changed, 7 insertions, 6 deletions
diff --git a/pc-bios/meson.build b/pc-bios/meson.build
index 03df50c485..fab323af84 100644
--- a/pc-bios/meson.build
+++ b/pc-bios/meson.build
@@ -1,7 +1,8 @@
-bzip2 = find_program('bzip2')
-
-install_blobs = 'INSTALL_BLOBS' in config_host
-if 'DECOMPRESS_EDK2_BLOBS' in config_host
+if 'arm-softmmu' in target_dirs or \
+ 'aarch64-softmmu' in target_dirs or \
+ 'i386-softmmu' in target_dirs or \
+ 'x86_64-softmmu' in target_dirs
+ bzip2 = find_program('bzip2', required: true)
fds = [
'edk2-aarch64-code.fd',
'edk2-arm-code.fd',
@@ -18,7 +19,7 @@ if 'DECOMPRESS_EDK2_BLOBS' in config_host
output: f,
input: '@0@.bz2'.format(f),
capture: true,
- install: install_blobs,
+ install: get_option('install_blobs'),
install_dir: qemu_datadir,
command: [ bzip2, '-dc', '@INPUT0@' ])
endforeach
@@ -85,7 +86,7 @@ blobs = files(
'npcm7xx_bootrom.bin',
)
-if install_blobs
+if get_option('install_blobs')
install_data(blobs, install_dir: qemu_datadir)
endif