aboutsummaryrefslogtreecommitdiff
path: root/pc-bios/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'pc-bios/meson.build')
-rw-r--r--pc-bios/meson.build27
1 files changed, 27 insertions, 0 deletions
diff --git a/pc-bios/meson.build b/pc-bios/meson.build
new file mode 100644
index 0000000000..6e3bfe3ca4
--- /dev/null
+++ b/pc-bios/meson.build
@@ -0,0 +1,27 @@
+bzip2 = find_program('bzip2')
+
+install_blobs = 'INSTALL_BLOBS' in config_host
+if 'DECOMPRESS_EDK2_BLOBS' in config_host
+ fds = [
+ 'edk2-aarch64-code.fd',
+ 'edk2-arm-code.fd',
+ 'edk2-arm-vars.fd',
+ 'edk2-i386-code.fd',
+ 'edk2-i386-secure-code.fd',
+ 'edk2-i386-vars.fd',
+ 'edk2-x86_64-code.fd',
+ 'edk2-x86_64-secure-code.fd',
+ ]
+
+ foreach f : fds
+ custom_target(f,
+ output: f,
+ input: '@0@.bz2'.format(f),
+ capture: true,
+ install: install_blobs,
+ install_dir: config_host['qemu_datadir'],
+ command: [ bzip2, '-dc', '@INPUT0@' ])
+ endforeach
+endif
+
+subdir('descriptors')