aboutsummaryrefslogtreecommitdiff
path: root/net/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'net/meson.build')
-rw-r--r--net/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/net/meson.build b/net/meson.build
index a53f18ad7b..9432a588e4 100644
--- a/net/meson.build
+++ b/net/meson.build
@@ -43,13 +43,13 @@ if have_vhost_net_user
system_ss.add(when: 'CONFIG_VIRTIO_NET', if_true: files('vhost-user.c'), if_false: files('vhost-user-stub.c'))
endif
-if targetos == 'windows'
+if host_os == 'windows'
system_ss.add(files('tap-win32.c'))
-elif targetos == 'linux'
+elif host_os == 'linux'
system_ss.add(files('tap.c', 'tap-linux.c'))
-elif targetos in bsd_oses
+elif host_os in bsd_oses
system_ss.add(files('tap.c', 'tap-bsd.c'))
-elif targetos == 'sunos'
+elif host_os == 'sunos'
system_ss.add(files('tap.c', 'tap-solaris.c'))
else
system_ss.add(files('tap.c', 'tap-stub.c'))