aboutsummaryrefslogtreecommitdiff
path: root/migration/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'migration/meson.build')
-rw-r--r--migration/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/migration/meson.build b/migration/meson.build
index f8714dcb15..8b5ca5c047 100644
--- a/migration/meson.build
+++ b/migration/meson.build
@@ -28,7 +28,9 @@ softmmu_ss.add(files(
), gnutls)
softmmu_ss.add(when: ['CONFIG_RDMA', rdma], if_true: files('rdma.c'))
-softmmu_ss.add(when: 'CONFIG_LIVE_BLOCK_MIGRATION', if_true: files('block.c'))
+if get_option('live_block_migration').allowed()
+ softmmu_ss.add(files('block.c'))
+endif
softmmu_ss.add(when: zstd, if_true: files('multifd-zstd.c'))
specific_ss.add(when: 'CONFIG_SOFTMMU',