aboutsummaryrefslogtreecommitdiff
path: root/migration/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'migration/meson.build')
-rw-r--r--migration/meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/migration/meson.build b/migration/meson.build
index 75de868bb7..eb41b77db9 100644
--- a/migration/meson.build
+++ b/migration/meson.build
@@ -13,8 +13,6 @@ softmmu_ss.add(files(
'block-dirty-bitmap.c',
'channel.c',
'channel-block.c',
- 'colo-failover.c',
- 'colo.c',
'exec.c',
'fd.c',
'global_state.c',
@@ -33,6 +31,10 @@ softmmu_ss.add(files(
'threadinfo.c',
), gnutls)
+if get_option('replication').allowed()
+ softmmu_ss.add(files('colo-failover.c', 'colo.c'))
+endif
+
softmmu_ss.add(when: rdma, if_true: files('rdma.c'))
if get_option('live_block_migration').allowed()
softmmu_ss.add(files('block.c'))