aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index a61d3e9b06..576bc2fdbd 100644
--- a/meson.build
+++ b/meson.build
@@ -1781,8 +1781,10 @@ if gnutls.found()
tasn1 = dependency('libtasn1',
method: 'pkg-config')
endif
-keyutils = dependency('libkeyutils', required: false,
- method: 'pkg-config')
+keyutils = not_found
+if get_option('keyring').enabled()
+ keyutils = dependency('libkeyutils', required: false, method: 'pkg-config')
+endif
has_gettid = cc.has_function('gettid')