aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index dd8016c9da..df5bf728b5 100644
--- a/meson.build
+++ b/meson.build
@@ -1068,12 +1068,13 @@ if 'CONFIG_XKBCOMMON' in config_host
dependencies: [qemuutil, xkbcommon], install: have_tools)
endif
+qemu_block_tools = []
if have_tools
qemu_img = executable('qemu-img', [files('qemu-img.c'), hxdep],
dependencies: [authz, block, crypto, io, qom, qemuutil], install: true)
qemu_io = executable('qemu-io', files('qemu-io.c'),
dependencies: [block, qemuutil], install: true)
- qemu_block_tools = [qemu_img, qemu_io]
+ qemu_block_tools += [qemu_img, qemu_io]
if targetos == 'linux' or targetos == 'sunos' or targetos.endswith('bsd')
qemu_nbd = executable('qemu-nbd', files('qemu-nbd.c'),
dependencies: [block, qemuutil], install: true)