aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 6 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 808f50b07e..dd8016c9da 100644
--- a/meson.build
+++ b/meson.build
@@ -1062,6 +1062,12 @@ if 'CONFIG_GUEST_AGENT' in config_host
subdir('qga')
endif
+if 'CONFIG_XKBCOMMON' in config_host
+ # used for the update-keymaps target, so include rules even if !have_tools
+ qemu_keymap = executable('qemu-keymap', files('qemu-keymap.c', 'ui/input-keymap.c') + genh,
+ dependencies: [qemuutil, xkbcommon], install: have_tools)
+endif
+
if have_tools
qemu_img = executable('qemu-img', [files('qemu-img.c'), hxdep],
dependencies: [authz, block, crypto, io, qom, qemuutil], install: true)
@@ -1078,11 +1084,6 @@ if have_tools
subdir('contrib/rdmacm-mux')
subdir('contrib/elf2dmp')
- if 'CONFIG_XKBCOMMON' in config_host
- executable('qemu-keymap', files('qemu-keymap.c', 'ui/input-keymap.c'),
- dependencies: [qemuutil, xkbcommon], install: true)
- endif
-
executable('qemu-edid', files('qemu-edid.c', 'hw/display/edid-generate.c'),
dependencies: qemuutil,
install: true)