aboutsummaryrefslogtreecommitdiff
path: root/hw/xen/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hw/xen/meson.build')
-rw-r--r--hw/xen/meson.build20
1 files changed, 12 insertions, 8 deletions
diff --git a/hw/xen/meson.build b/hw/xen/meson.build
index 076954b89c..08dc1f6857 100644
--- a/hw/xen/meson.build
+++ b/hw/xen/meson.build
@@ -8,13 +8,17 @@ softmmu_ss.add(when: ['CONFIG_XEN', xen], if_true: files(
))
xen_specific_ss = ss.source_set()
-xen_specific_ss.add(when: 'CONFIG_XEN_PCI_PASSTHROUGH', if_true: files(
- 'xen-host-pci-device.c',
- 'xen_pt.c',
- 'xen_pt_config_init.c',
- 'xen_pt_graphics.c',
- 'xen_pt_load_rom.c',
- 'xen_pt_msi.c',
-), if_false: files('xen_pt_stub.c'))
+if have_xen_pci_passthrough
+ xen_specific_ss.add(files(
+ 'xen-host-pci-device.c',
+ 'xen_pt.c',
+ 'xen_pt_config_init.c',
+ 'xen_pt_graphics.c',
+ 'xen_pt_load_rom.c',
+ 'xen_pt_msi.c',
+ ))
+else
+ xen_specific_ss.add('xen_pt_stub.c')
+endif
specific_ss.add_all(when: ['CONFIG_XEN', xen], if_true: xen_specific_ss)