aboutsummaryrefslogtreecommitdiff
path: root/hw/openrisc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hw/openrisc/meson.build')
-rw-r--r--hw/openrisc/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/hw/openrisc/meson.build b/hw/openrisc/meson.build
index 2dbc6365bb..82f1f0ef1c 100644
--- a/hw/openrisc/meson.build
+++ b/hw/openrisc/meson.build
@@ -1,7 +1,7 @@
openrisc_ss = ss.source_set()
openrisc_ss.add(files('cputimer.c'))
openrisc_ss.add(files('boot.c'))
-openrisc_ss.add(when: 'CONFIG_OR1K_SIM', if_true: [files('openrisc_sim.c'), fdt])
-openrisc_ss.add(when: 'CONFIG_OR1K_VIRT', if_true: [files('virt.c'), fdt])
+openrisc_ss.add(when: 'CONFIG_OR1K_SIM', if_true: files('openrisc_sim.c'))
+openrisc_ss.add(when: 'CONFIG_OR1K_VIRT', if_true: files('virt.c'))
hw_arch += {'openrisc': openrisc_ss}