aboutsummaryrefslogtreecommitdiff
path: root/hw/loongarch/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hw/loongarch/meson.build')
-rw-r--r--hw/loongarch/meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/hw/loongarch/meson.build b/hw/loongarch/meson.build
index cecb1a5d65..6a2a1b18e5 100644
--- a/hw/loongarch/meson.build
+++ b/hw/loongarch/meson.build
@@ -1,4 +1,8 @@
loongarch_ss = ss.source_set()
-loongarch_ss.add(when: 'CONFIG_LOONGARCH_VIRT', if_true: files('loongson3.c'))
+loongarch_ss.add(files(
+ 'fw_cfg.c',
+))
+loongarch_ss.add(when: 'CONFIG_LOONGARCH_VIRT', if_true: [files('loongson3.c'), fdt])
+loongarch_ss.add(when: 'CONFIG_ACPI', if_true: files('acpi-build.c'))
hw_arch += {'loongarch': loongarch_ss}